python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / libcap / libcap_1.10.bb
blobe6ca393df7e91f1de3a6c95f6035bdeebc7eb9e4
1 DESCRIPTION = "Libcap is a library for getting and setting POSIX.1e (formerly POSIX 6) draft 15 capabilities."
2 PRIORITY = "optional"
3 SECTION = "libs"
4 LICENSE = "GPL"
5 DEPENDS = "bison-native flex-native"
6 PR = "r2"
8 CFLAGS_append = " -I${S}/libcap/include -fPIC"
10 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/security/linux-privs/kernel-2.4/${PN}-${PV}.tar.bz2 \
11 file://makenames.patch \
12 file://make.patch \
13 file://syscall.patch"
15 FILES_${PN} = "${libdir}"
16 FILES_${PN}-dev = "${includedir}"
18 do_install() {
19 install -d ${D}${includedir}/sys
20 install -m 0644 libcap/include/sys/capability.h ${D}${includedir}/sys/
21 install -d ${D}${libdir}
22 oe_libinstall -s -C libcap libcap ${D}${libdir}
25 do_stage() {
26 install -d ${STAGING_INCDIR}/sys
27 install -m 0644 libcap/include/sys/capability.h ${STAGING_INCDIR}/sys/
28 oe_libinstall -s -C libcap libcap ${STAGING_LIBDIR}
31 SRC_URI[md5sum] = "4426a413128142cab89eb2e6f13d8571"
32 SRC_URI[sha256sum] = "66c3f033fdc8f9ba0bd9d0ae2d1f2c11f9fa51bf0d1418e5cb75e29e6577a5bc"