python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / gstreamer / gst-plugins-base_0.10.30.bb
blob08265626bd6372a532100e4c85b30d88f5c0fc1e
1 require gst-plugins.inc
3 SRC_URI += " \
4 file://ivorbis-thumb.patch \
5 file://make382.patch \
8 SRC_URI[archive.md5sum] = "3ad90152b58563e1314af26c263f3c4c"
9 SRC_URI[archive.sha256sum] = "63938641380be9935c804ae8d55acdcfd93920ed2deb72dcf70f027a78b085d7"
11 PR = "${INC_PR}.0"
13 PROVIDES += "gst-plugins"
15 # gst-plugins-base only builds the alsa plugin
16 # if alsa has been built and is present. You will
17 # not get an error if this is not present, just
18 # a missing alsa plugin
19 DEPENDS += "udev cdparanoia pango libtheora alsa-lib libsm virtual/libx11 freetype gnome-vfs libxv gtk+"
21 # Needs a udev that enabled gudev, which isn't the default
22 EXTRA_OECONF_append = " --with-gudev"
24 do_configure_prepend() {
25 sed -i -e s:QtGui:NoQtGui:g ${S}/configure.ac