python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / gstreamer / gst-plugins-base_0.10.28.bb
blob000761f0dfc81fdec9cb31936a8abec4445bab48
1 require gst-plugins.inc
3 SRC_URI += " \
4 file://gst-plugins-base_rowstride.patch \
5 file://ivorbis-thumb.patch \
8 SRC_URI[archive.md5sum] = "0107cf985ac90544bae70288220f5bab"
9 SRC_URI[archive.sha256sum] = "132b6fd7749fcbfa9ad88c854aada44b6870c4175bda21cdb01a52b59a98e14f"
11 PR = "${INC_PR}.1"
13 PROVIDES += "gst-plugins"
15 # gst-plugins-base only builds the alsa plugin
16 # if alsa has been built and is present. You will
17 # not get an error if this is not present, just
18 # a missing alsa plugin
19 DEPENDS += "udev cdparanoia pango libtheora alsa-lib libsm virtual/libx11 freetype gnome-vfs libxv"
21 # Needs a udev that enabled gudev, which isn't the default
22 EXTRA_OECONF_append = " --with-gudev"
24 do_configure_prepend() {
25 sed -i -e s:QtGui:NoQtGui:g ${S}/configure.ac