python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / glibc / glibc-initial_2.5.bb
blob35c9febccec3dd931908dcfab28b5936f72cf924
1 require glibc_${PV}.bb
2 require glibc-initial.inc
4 do_configure () {
5 sed -ie 's,{ (exit 1); exit 1; }; },{ (exit 0); }; },g' ${S}/configure
6 chmod +x ${S}/configure
7 unset CFLAGS
8 ${S}/configure --host=${TARGET_SYS} --build=${BUILD_SYS} \
9 --without-cvs --disable-sanity-checks \
10 --with-headers=${STAGING_INCDIR} \
11 --enable-hacker-mode
12 if grep -q GLIBC_2.5 ${S}/ChangeLog; then
13 # glibc-2.3.x passes cross options to $(CC) when generating errlist-compat.c, which fails without a real cross-compiler.
14 # Fortunately, we don't need errlist-compat.c, since we just need .h files,
15 # so work around this by creating a fake errlist-compat.c and satisfying its dependencies.
16 # Another workaround might be to tell configure to not use any cross options to $(CC).
17 # The real fix would be to get install-headers to not generate errlist-compat.c.
18 make sysdeps/gnu/errlist.c
19 mkdir -p stdio-common
20 touch stdio-common/errlist-compat.c