python-pyrex: Rework DEPENDS updates
[openembedded.git] / recipes / freetype / freetype_2.3.6.bb
blobe92bef8870da5646b43dc589f79f3bc323b0ccbe
1 DESCRIPTION = "Freetype font rendering library"
2 SECTION = "libs"
3 LICENSE = "freetype GPLv2"
4 PR = "r0"
6 SRC_URI = "\
7 ${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
8 file://no-hardcode.patch \
9 file://fix-configure.patch \
10 file://libtool-tag.patch \
12 S = "${WORKDIR}/freetype-${PV}"
14 inherit autotools pkgconfig binconfig
16 LIBTOOL = "${HOST_SYS}-libtool"
17 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
18 EXTRA_OECONF = "--without-zlib"
20 do_configure() {
21 cd builds/unix
22 libtoolize --force --copy
23 gnu-configize --force
24 aclocal -I .
25 autoconf
26 cd ${S}
27 oe_runconf
30 do_compile_prepend() {
31 ${BUILD_CC} -o objs/apinames src/tools/apinames.c
34 FILES_${PN} = "${libdir}/lib*.so.*"
35 FILES_${PN}-dev += "${bindir}"
37 SRC_URI[md5sum] = "fb182d508017cb608e9df8c7dca648dc"
38 SRC_URI[sha256sum] = "d5a698c30376d14c1ce6540ed6d5627796421e6e97576620ea4562411a110e77"