omapfbplay: bump PR
[openembedded.git] / recipes / ffmpeg / omapfbplay_git.bb
blobbbbc2baa63a82acc955e66ebd528a51a97af0376
1 DESCRIPTION = "Simple ffmpeg-based player that uses the omapfb overlays"
2 DEPENDS = "bzip2 lame ffmpeg virtual/kernel"
3 LICENSE = "MIT"
5 PR = "r19"
7 PV = "0.0+${PR}+gitr${SRCREV}"
9 SRCREV = "26df4208b57ccb0f0ca101ae4ddb92c956a0ecc0"
10 SRC_URI = "git://git.mansr.com/${PN};protocol=git \
11 file://fbplay-static.diff "
13 S = "${WORKDIR}/git"
15 # We want a kernel header for armv7a, but we don't want to make mplayer machine specific for that
16 STAGING_KERNEL_DIR = "${STAGING_DIR}/${MACHINE_ARCH}${TARGET_VENDOR}-${TARGET_OS}/kernel"
18 CFLAGS += " -I. -I${STAGING_KERNEL_DIR}/include "
20 do_compile() {
21 cp ${STAGING_KERNEL_DIR}/arch/arm/plat-omap/include/mach/omapfb.h ${S} || true
22 cp ${STAGING_KERNEL_DIR}/include/asm-arm/arch-omap/omapfb.h ${S} || true
23 cp ${STAGING_KERNEL_DIR}/include/linux/omapfb.h ${S} || true
24 oe_runmake -e
27 do_install() {
28 install -d ${D}/${bindir}
29 install -m 0755 ${S}/omapfbplay ${D}/${bindir}/