ti-dmai: pass c6accel location to makefile
[openembedded.git] / classes / openmoko2.bbclass
blob25dea8232caab6dcaa182cd9c6238b506354d300
1 inherit autotools pkgconfig
3 HOMEPAGE = "http://www.openmoko.org"
4 OPENMOKO_RELEASE ?= "OM-2007.2"
5 OPENMOKO_MIRROR ?= "svn://svn.openmoko.org/trunk"
7 def openmoko_two_get_license(d):
8     if bb.data.getVar('SECTION', d, 1).find("/") != -1:
9         openmoko, section = bb.data.getVar('SECTION', d, 1).split("/")
10     else:
11         section = bb.data.getVar('SECTION', d, 1)       
12     return "LGPL GPL".split()[section != "libs"]
14 def openmoko_two_get_subdir(d):
15     if bb.data.getVar('SECTION', d, 1).find("/") != -1:
16         openmoko, section = bb.data.getVar('SECTION', d, 1).split("/")
17     else:
18         section = bb.data.getVar('SECTION', d, 1)
19     if section == 'base': return ""
20     elif section == 'libs': return "libraries"
21     elif section in 'apps tools pim'.split(): return "applications"
22     elif section == "panel-plugin": return "panel-plugins"
23     elif section == "inputmethods": return "inputmethods"
24     elif section == "daemons": return "daemons"
25     elif section == "misc": return "misc"
26     else: return section
28 LICENSE = "${@openmoko_two_get_license(d)}"
29 SUBDIR = "${@openmoko_two_get_subdir(d)}"
31 SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/${SUBDIR};module=${PN};proto=http"
32 S = "${WORKDIR}/${PN}"
34 FILES_${PN} += "${datadir}/icons"
36 SVNREV = "r${SRCREV}"
37 #SVNREV = "${SRCDATE}"