thttpd: update package LICENSE
[openembedded.git] / recipes / thttpd / thttpd_2.25b.bb
blobbf035259e12888633ab61d7b65d9df265477ec2e
1 DESCRIPTION = "A simple, small, portable, fast, and secure HTTP server."
2 LICENSE = "FreeBSD"
3 HOMEPAGE = "http://www.acme.com/software/thttpd/"
4 PR ="r8"
6 SRC_URI = "http://www.acme.com/software/thttpd/thttpd-2.25b.tar.gz \
7 file://install.patch \
8 file://acinclude.m4 \
9 file://init \
10 file://htpasswd_shared.diff \
11 file://htpasswd_getline.diff"
12 S = "${WORKDIR}/thttpd-${PV}"
14 PARALLEL_MAKE = ""
16 INITSCRIPT_NAME = "thttpd"
17 INITSCRIPT_PARAMS = "defaults"
19 inherit autotools update-rc.d
21 EXTRA_OEMAKE += "'WEBDIR=${servicedir}/www'"
22 FILES_${PN}-dbg_append = " ${servicedir}/www/cgi-bin/.debug"
23 FILES_${PN}_append = " ${servicedir}"
25 do_configure () {
26 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
27 autotools_do_configure
30 do_install_append () {
31 install -d "${D}${sysconfdir}/init.d"
32 cat ${WORKDIR}/init | sed -e 's,@@SRVDIR,${servicedir}/www,g' > ${WORKDIR}/thttpd
33 install -c -m 755 ${WORKDIR}/thttpd ${D}${sysconfdir}/init.d/thttpd
37 SRC_URI[md5sum] = "156b249b3b0bcd48b06badd2db0d56c5"
38 SRC_URI[sha256sum] = "07719b08b1cff6a21c08697a7bcb4395425b07ee753106262fb62a03a7d32360"