ti-syslink 2.00.00.78: import from meta-ti
[openembedded.git] / recipes / gs / gs-tools-native_8.64.bb
blobea5f5fad0e4e112fc816f90f26c4069fbcc467e9
1 DESCRIPTION = "Tools needed for cross building Ghostscript"
2 LICENSE = "GPLv2"
3 HOMEPAGE = "http://www.gnu.org/software/ghostscript/ghostscript.html"
4 DEPENDS = "zlib-native fontconfig-native"
6 S = "${WORKDIR}/ghostscript-${PV}~dfsg"
7 SRC_URI = "${DEBIAN_MIRROR}/main/g/ghostscript/ghostscript_${PV}~dfsg.orig.tar.gz;name=tarball"
9 inherit autotools native
11 SRC_URI[tarball.md5sum] = "e42706c2409815df5c959484080fd4a3"
12 SRC_URI[tarball.sha256sum] = "cc856d33cb781cdc3383b8eb4e0f390997f8359fe144a906b84297b5d377f03d"
14 EXTRA_OECONF = "--without-x --without-jasper"
16 do_compile() {
17 mkdir -p obj
18 for i in genarch genconf mkromfs echogs gendev genht; do
19 oe_runmake obj/$i
20 done
23 NATIVE_INSTALL_WORKS = "1"
25 do_install () {
26 install -d ${D}${bindir}/gs-tools-${PV}
27 for i in genarch genconf mkromfs echogs gendev genht; do
28 install -m 755 obj/$i ${D}${bindir}/gs-tools-${PV}/$i
29 done