linphone: fix build without NLS enabled
[openembedded.git] / recipes / yum / createrepo-native_0.9.bb
bloba74dabf7847716316dbe4e59bfd733bd0aef1225
1 DEPENDS = "python-native"
3 SRC_URI = "http://createrepo.baseurl.org/download/createrepo-${PV}.tar.gz \
4 file://fix.patch \
5 file://pathfix.patch "
6 PR = "r1"
8 inherit autotools native
10 S = "${WORKDIR}/createrepo-${PV}"
12 do_compile_append () {
13 sed -e 's#exec /usr/share#exec ${datadir}#' -i ${S}/bin/createrepo
14 sed -e 's#exec /usr/share#exec ${datadir}#' -i ${S}/bin/modifyrepo
15 sed -e 's#!/usr/bin/python#!${bindir}/python#' -i ${S}/genpkgmetadata.py
16 sed -e 's#!/usr/bin/python#!${bindir}/python#' -i ${S}/modifyrepo.py
19 SRC_URI[md5sum] = "0a1b1e67e3c61cda41b41a8886a90e78"
20 SRC_URI[sha256sum] = "21786abe80f2c06eb9bef107d8c79f50a088a894cddf793112ce0417e83be531"