linphone: fix build without NLS enabled
[openembedded.git] / recipes / dhcdbd / dhcdbd_1.14.bb
blob69d11d6ed28c87505580d1d204f26a1c61ad3197
1 DESCRIPTION = "DBus-enabled dhcp client"
2 HOMEPAGE = "http://people.redhat.com/jvdias/dhcdbd/"
3 SECTION = "net"
4 LICENSE = "GPL"
5 DEPENDS = "dbus"
7 PR = "r1"
9 SRC_URI = "https://fedorahosted.org/releases/d/h/dhcdbd/dhcdbd-${PV}.tar.bz2 \
10 file://dhcdbd-1.14-pkgconfig_dbus.patch \
11 file://dbus-api-fix.patch \
12 file://dhcdbd"
14 do_compile() {
15 CC=${TARGET_SYS}-gcc DESTDIR=${prefix} make
18 do_install() {
19 DESTDIR=${D} make install
20 install -d ${D}/etc/init.d
21 install -m 0755 ${WORKDIR}/dhcdbd ${D}/etc/init.d/
24 FILES_${PN} += "${sysconfdir} ${datadir}/dbus-1 ${base_sbindir}/*"
26 SRC_URI[md5sum] = "1180dee7a51a4384d55768650634cf93"
27 SRC_URI[sha256sum] = "e5facfcab28377d32fd4c70aa1fe0820d3dba4abdfc48bd15eda712c8815e505"