1 DESCRIPTION
= "The Battle for Wesnoth is a turn-based strategy game with a fantasy theme."
2 HOMEPAGE
= "http://www.wesnoth.org/"
6 DEPENDS
= "freetype libsdl-image libsdl-mixer libsdl-net libsdl-ttf zlib boost imagemagick-native pango libpng"
9 SRC_URI
= "${SOURCEFORGE_MIRROR}/wesnoth/${PN}-${PV}.tar.bz2"
10 SRC_URI
[md5sum
] = "62ba3a4938d3e722797cfbe9450d3e36"
11 SRC_URI
[sha256sum
] = "985d40ff04cf95bb6f8abb3353ec955c3286a6f9edb1bd29b6f26f8b12280928"
13 ARM_INSTRUCTION_SET
= "arm"
21 -DENABLE_FRIBIDI=OFF \
23 -DCMAKE_BUILD_TYPE=Debug \
26 PACKAGES
= "wesnoth-editor wesnoth-doc wesnoth-music wesnoth-sounds \
27 wesnoth-aoi wesnoth-did wesnoth-ei wesnoth-httt wesnoth-l \
28 wesnoth-nr wesnoth-sof wesnoth-sotbe wesnoth-thot wesnoth-trow \
29 wesnoth-tsg wesnoth-tb wesnoth-utbs wesnoth-low\
31 wesnoth-all-campaigns \
37 DESCRIPTION_wesnoth
-editor
= "Map Editor for The Battle for Wesnoth"
38 DESCRIPTION_wesnoth
-all
= "The Battle for Wesnoth with all campaigns, music and sounds"
39 DESCRIPTION_wesnoth
-all
-campaigns
= "The Battle for Wesnoth with all campaigns."
40 DESCRIPTION_wesnoth
-sounds
= "Optional sound package for The Battle for Wesnoth"
41 DESCRIPTION_wesnoth
-music
= "Optional music package for The Battle for Wesnoth"
42 DESCRIPTION_wesnoth
-data = "Mandatory data package for The Battle for Wesnoth"
43 DESCRIPTION_wesnothd
= "Optional Battle for Wesnoth server"
45 do_configure_prepend
(){
46 export HOST_SYS
="${HOST_SYS}"
47 export BUILD_SYS
="${BUILD_SYS}"
48 export STAGING_LIBDIR
="${STAGING_LIBDIR}"
49 export STAGING_INCDIR
="${STAGING_INCDIR}"
50 rm
-f $
{S
}/cmake
/FindBoost.cmake
54 #ugly hack but otherwise it would have required
to
55 #have MANDIR
:STRING=share
/man that would require a
56 #second python
function
57 if [ -d $
{D
}$
{prefix
}/man
];then
58 mv $
{D
}$
{prefix
}/man $
{D
}$
{mandir
}
62 RDEPENDS_wesnoth
= "wesnoth-data libpng"
64 RDEPENDS_wesnoth
-editor
= "wesnoth-data"
66 RDEPENDS_wesnoth
-all
-campaigns
= "wesnoth \
67 wesnoth-aoi wesnoth-did wesnoth-ei wesnoth-httt wesnoth-l \
68 wesnoth-nr wesnoth-sof wesnoth-sotbe wesnoth-thot wesnoth-trow \
69 wesnoth-tsg wesnoth-tb wesnoth-utbs wesnoth-low"
71 # Installing wesnoth
-all should pull everything in
(like in Debian
).
72 RDEPENDS_wesnoth
-all
= "wesnoth wesnoth-sounds wesnoth-music"
74 FILES_wesnoth
-music
= "\
75 ${datadir}/wesnoth/data/core/music \
78 FILES_wesnoth
-sounds
= "\
79 ${datadir}/wesnoth/data/core/sounds \
82 # Picks up remaining translations
and data. Must be packaged
after
83 # wesnoth
-music
, wesnoth
-sounds
and all campaigns.
84 FILES_wesnoth
-data = "\
85 ${datadir}/wesnoth/sounds \
86 ${datadir}/wesnoth/images \
87 ${datadir}/wesnoth/data \
88 ${datadir}/wesnoth/fonts \
89 ${datadir}/wesnoth/translations \
95 ${datadir}/applications/wesnoth.desktop \
96 ${datadir}/pixmaps/wesnoth-icon.png \
103 FILES_wesnoth
-low
="\
104 ${datadir}/wesnoth/data/campaigns/Legend_of_Wesmere \
105 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-aoi.mo \
108 FILES_wesnoth
-editor
= "\
109 ${bindir}/wesnoth_editor \
110 ${datadir}/applications/wesnoth_editor.desktop \
111 ${datadir}/pixmaps/wesnoth_editor-icon.png \
114 FILES_wesnoth
-aoi
= "\
115 ${datadir}/wesnoth/data/campaigns/An_Orcish_Incursion \
116 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-aoi.mo \
119 FILES_wesnoth
-did
= "\
120 ${datadir}/wesnoth/data/campaigns/Descent_Into_Darkness \
121 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-did.mo \
124 FILES_wesnoth
-ei
= "\
125 ${datadir}/wesnoth/data/campaigns/Eastern_Invasion \
126 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-ei.mo \
129 FILES_wesnoth
-httt
= "\
130 ${datadir}/wesnoth/data/campaigns/Heir_To_The_Throne \
131 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-httt.mo \
135 ${datadir}/wesnoth/data/campaigns/Liberty \
136 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-l.mo \
139 FILES_wesnoth
-nr
= "\
140 ${datadir}/wesnoth/data/campaigns/Northern_Rebirth \
141 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-nr.mo \
144 FILES_wesnoth
-sof
= "\
145 ${datadir}/wesnoth/data/campaigns/Sceptre_Of_Fire \
146 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-sof.mo \
149 FILES_wesnoth
-sotbe
= "\
150 ${datadir}/wesnoth/data/campaigns/Son_Of_The_Black_Eye \
151 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-sotbe.mo \
154 FILES_wesnoth
-thot
= "\
155 ${datadir}/wesnoth/data/campaigns/The_Hammer_Of_Thursagan \
156 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-thot.mo \
159 FILES_wesnoth
-trow
= "\
160 ${datadir}/wesnoth/data/campaigns/The_Rise_Of_Wesnoth \
161 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-trow.mo \
164 FILES_wesnoth
-tsg
= "\
165 ${datadir}/wesnoth/data/campaigns/The_South_Guard \
166 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-tsg.mo \
169 FILES_wesnoth
-tb
= "\
170 ${datadir}/wesnoth/data/campaigns/Two_Brothers \
171 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-tb.mo \
174 FILES_wesnoth
-utbs
= "\
175 ${datadir}/wesnoth/data/campaigns/Under_the_Burning_Suns \
176 ${datadir}/wesnoth/translations/*/LC_MESSAGES/wesnoth-utbs.mo \