ivman: oops recipe got doubled, fix it
[openembedded.git] / classes / sanity.bbclass
blob7aabe042830e1c9e2bd75bfb5e91b1731652709a
2 # Sanity check the users setup for common misconfigurations
5 def raise_sanity_error(msg):
6         import bb
7         bb.fatal(""" Openembedded's config sanity checker detected a potential misconfiguration.
8         Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
9         Following is the list of potential problems / advisories:
10         
11         %s""" % msg)
13 def check_conf_exists(fn, data):
14         import bb, os
16         bbpath = []
17         fn = bb.data.expand(fn, data)
18         vbbpath = bb.data.getVar("BBPATH", data)
19         if vbbpath:
20                 bbpath += vbbpath.split(":")
21         for p in bbpath:
22                 currname = os.path.join(bb.data.expand(p, data), fn)
23                 if os.access(currname, os.R_OK):
24                         return True
25         return False
27 def check_sanity(e):
28         from bb import note, error, data, __version__
29         from bb.event import Handled, NotHandled, getName
30         try:
31                 from distutils.version import LooseVersion
32         except ImportError:
33                 def LooseVersion(v): print "WARNING: sanity.bbclass can't compare versions without python-distutils"; return 1
34         import os, commands
36         # Check the bitbake version meets minimum requirements
37         minversion = data.getVar('BB_MIN_VERSION', e.data , True)
38         if not minversion:
39                 # Hack: BB_MIN_VERSION hasn't been parsed yet so return 
40                 # and wait for the next call
41                 print "Foo %s" % minversion
42                 return
44         if 0 == os.getuid():
45                 raise_sanity_error("Do not use Bitbake as root.")
47         messages = ""
49         if (LooseVersion(__version__) < LooseVersion(minversion)):
50                 messages = messages + 'Bitbake version %s is required and version %s was found\n' % (minversion, __version__)
52         # Check TARGET_ARCH is set
53         if data.getVar('TARGET_ARCH', e.data, True) == 'INVALID':
54                 messages = messages + 'Please set TARGET_ARCH directly, or choose a MACHINE or DISTRO that does so.\n'
55         
56         # Check TARGET_OS is set
57         if data.getVar('TARGET_OS', e.data, True) == 'INVALID':
58                 messages = messages + 'Please set TARGET_OS directly, or choose a MACHINE or DISTRO that does so.\n'
60         assume_provided = data.getVar('ASSUME_PROVIDED', e.data , True).split()
61         # Check user doesn't have ASSUME_PROVIDED = instead of += in local.conf
62         if "diffstat-native" not in assume_provided:
63                 messages = messages + 'Please use ASSUME_PROVIDED +=, not ASSUME_PROVIDED = in your local.conf\n'
64         
65         # Check that the MACHINE is valid, if it is set
66         if data.getVar('MACHINE', e.data, True):
67                 if not check_conf_exists("conf/machine/${MACHINE}.conf", e.data):
68                         messages = messages + 'Please set a valid MACHINE in your local.conf\n'
69         
70         # Check that the DISTRO is valid
71         # need to take into account DISTRO renaming DISTRO
72         if not ( check_conf_exists("conf/distro/${DISTRO}.conf", e.data) or check_conf_exists("conf/distro/include/${DISTRO}.inc", e.data) ):
73                 messages = messages + "DISTRO '%s' not found. Please set a valid DISTRO in your local.conf\n" % data.getVar("DISTRO", e.data, True )
75         missing = ""
77         if not check_app_exists("${MAKE}", e.data):
78                 missing = missing + "GNU make,"
80         if not check_app_exists('${BUILD_PREFIX}gcc', e.data):
81                 missing = missing + "C Compiler (${BUILD_PREFIX}gcc),"
83         if not check_app_exists('${BUILD_PREFIX}g++', e.data):
84                 missing = missing + "C++ Compiler (${BUILD_PREFIX}g++),"
86         required_utilities = "patch help2man diffstat texi2html makeinfo cvs svn bzip2 tar gzip gawk md5sum"
88         if data.getVar('TARGET_ARCH', e.data, True) == "arm":
89                 # qemu-native needs gcc 3.x
90                 if "qemu-native" not in assume_provided and "gcc3-native" in assume_provided:
91                         gcc_version = commands.getoutput("${BUILD_PREFIX}gcc --version | head -n 1 | cut -f 3 -d ' '")
93                         if not check_gcc3(e.data) and gcc_version[0] != '3':
94                                 messages = messages + "gcc3-native was in ASSUME_PROVIDED but the gcc-3.x binary can't be found in PATH"
95                                 missing = missing + "gcc-3.x (needed for qemu-native),"
97                 if "qemu-native" in assume_provided:
98                         if not check_app_exists("qemu-arm", e.data):
99                                 messages = messages + "qemu-native was in ASSUME_PROVIDED but the QEMU binaries (qemu-arm) can't be found in PATH"
101                 if os.path.exists("/proc/sys/vm/mmap_min_addr"):
102                         f = file("/proc/sys/vm/mmap_min_addr", "r")
103                         if (f.read().strip() != "0"):
104                                 messages = messages + "/proc/sys/vm/mmap_min_addr is not 0. This will cause problems with qemu so please fix the value (as root).\n"
105                         f.close()
107         for util in required_utilities.split():
108                 if not check_app_exists( util, e.data ):
109                         missing = missing + "%s," % util
111         if missing != "":
112                 missing = missing.rstrip(',')
113                 messages = messages + "Please install following missing utilities: %s\n" % missing
115         omask = os.umask(022)
116         if omask & 0755:
117                 messages = messages + "Please use a umask which allows a+rx and u+rwx\n"
118         os.umask(omask)
120         oes_bb_conf = data.getVar( 'OES_BITBAKE_CONF', e.data, True )
121         if not oes_bb_conf:
122                 messages = messages + 'You do not include OpenEmbeddeds version of conf/bitbake.conf. This means your environment is misconfigured, in particular check BBPATH.\n'
124         #
125         # Check that TMPDIR hasn't changed location since the last time we were run
126         #
127         tmpdir = data.getVar('TMPDIR', e.data, True)
128         checkfile = os.path.join(tmpdir, "saved_tmpdir")
129         if os.path.exists(checkfile):
130                 f = file(checkfile, "r")
131                 if (f.read().strip() != tmpdir):
132                         messages = messages + "Error, TMPDIR has changed location. You need to either move it back to %s or rebuild\n" % tmpdir
133         else:
134                 f = file(checkfile, "w")
135                 f.write(tmpdir)
136         f.close()
138         #
139         # Check the 'ABI' of TMPDIR
140         #
141         current_abi = data.getVar('SANITY_ABI', e.data, True)
142         abifile = data.getVar('SANITY_ABIFILE', e.data, True)
143         if os.path.exists(abifile):
144                 f = file(abifile, "r")
145                 abi = f.read().strip()
146                 if not abi.isdigit():
147                         f = file(abifile, "w")
148                         f.write(current_abi)
149                 elif (abi != current_abi):
150                         # Code to convert from one ABI to another could go here if possible.
151                         messages = messages + "Error, TMPDIR has changed ABI (%s to %s) and you need to either rebuild, revert or adjust it at your own risk.\n" % (abi, current_abi)
152         else:
153                 f = file(abifile, "w")
154                 f.write(current_abi)
155         f.close()
157         if messages != "":
158                 raise_sanity_error(messages)
160 addhandler check_sanity_eventhandler
161 python check_sanity_eventhandler() {
162     from bb import note, error, data, __version__
163     from bb.event import getName
165     if getName(e) == "ConfigParsed":
166         check_sanity(e)
168     return NotHandled