ivman: oops recipe got doubled, fix it
[openembedded.git] / classes / gnome.bbclass
blob133859d5a03fa5659f15b8cb85cdfe3740c59e69
1 def gnome_verdir(v):
2         import re
3         m = re.match("^([0-9]+)\.([0-9]+)", v)
4         return "%s.%s" % (m.group(1), m.group(2))
6 SECTION ?= "x11/gnome"
7 SRC_URI = "${GNOME_MIRROR}/${PN}/${@gnome_verdir("${PV}")}/${PN}-${PV}.tar.bz2"
9 DEPENDS += "gnome-common"
11 FILES_${PN} += "${datadir}/application-registry ${datadir}/mime-info \
12         ${datadir}/gnome-2.0"
14 inherit autotools pkgconfig gconf
16 AUTOTOOLS_STAGE_PKGCONFIG = "1"
18 gnome_stage_includes() {
19         autotools_stage_includes