Add bwm-ng 0.6: lightweight network and disk bandwidth monitor
[openembedded.git] / recipes / glibc / glibc_2.3.2.bb
blob0ed7d3e72364ddf652bcf51b4a252253b74e48ef
1 require glibc.inc
3 PR = "r20"
5 DEFAULT_PREFERENCE_sh3 = "-99"
7 GLIBC_ADDONS ?= "linuxthreads"
10 # For now, we will skip building of a gcc package if it is a uclibc one
11 # and our build is not a uclibc one, and we skip a glibc one if our build
12 # is a uclibc build.
14 # See the note in gcc/gcc_3.4.0.oe
17 python __anonymous () {
18 import bb, re
19 uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
20 if uc_os:
21 raise bb.parse.SkipPackage("incompatible with target %s" %
22 bb.data.getVar('TARGET_OS', d, 1))
25 libc_baselibs = "/lib/libc* /lib/libm* /lib/ld* /lib/libpthread* /lib/libresolv* /lib/librt* /lib/libutil* /lib/libnsl* /lib/libnss_files* /lib/libnss_compat* /lib/libnss_dns* /lib/libdl* /lib/libanl* /lib/libBrokenLocale*"
27 FILES_${PN} = "${sysconfdir} ${libc_baselibs} /sbin/ldconfig ${libexecdir} ${datadir}/zoneinfo"
28 FILES_ldd = "${bindir}/ldd"
29 FILES_libsegfault = "/lib/libSegFault*"
30 FILES_glibc-extra-nss = "/lib/libnss*"
31 FILES_sln = "/sbin/sln"
32 FILES_glibc-dev_append = " ${libdir}/*.o ${bindir}/rpcgen"
33 FILES_nscd = "${sbindir}/nscd*"
34 FILES_glibc-utils = "${bindir} ${sbindir}"
35 FILES_glibc-gconv = "${libdir}/gconv"
36 FILES_catchsegv = "${bindir}/catchsegv"
37 DEPENDS_catchsegv = "libsegfault"
38 FILES_glibc-pcprofile = "/lib/libpcprofile.so"
39 FILES_glibc-thread-db = "/lib/libthread_db*"
40 FILES_localedef = "${bindir}/localedef"
41 RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
42 RPROVIDES_${PN}-dev += "libc-dev virtual-libc-dev"
44 SRC_URI = "ftp://ftp.gnu.org/gnu/glibc/glibc-${PV}.tar.gz \
45 ftp://ftp.gnu.org/pub/gnu/glibc/glibc-linuxthreads-2.3.2.tar.gz \
46 file://noinfo.patch;patch=1 \
47 file://10_cvs.patch;patch=1 \
48 file://arm-ioperm.patch;patch=1;pnum=0 \
49 file://glibc-i686-timing.patch;patch=1;pnum=1 \
50 file://makeconfig.patch;patch=1;pnum=0 \
51 file://locale-es_AR.patch;patch=1;pnum=0 \
52 file://ldconfig.patch;patch=1;pnum=0 \
53 file://ldd.patch;patch=1;pnum=0 \
54 file://fhs-linux-paths.patch;patch=1;pnum=1 \
55 file://glibc22-nss-upgrade.patch;patch=1;pnum=1 \
56 file://glibc22-eo_EO.patch;patch=1;pnum=1 \
57 file://glibc22-m68k-compat.patch;patch=1;pnum=1 \
58 file://glibc22-m68k-fpic.patch;patch=1;pnum=1 \
59 file://glibc22-locales.patch;patch=1;pnum=0 \
60 file://sparc64-fixups.patch;patch=1;pnum=1 \
61 file://glibc22-ttyname-devfs.patch;patch=1;pnum=0 \
62 file://powerpc-sysconf.patch;patch=1;pnum=1 \
63 file://arm-no-hwcap.patch;patch=1;pnum=0 \
64 file://locales-stuff.patch;patch=1;pnum=1 \
65 file://librt-mips.patch;patch=1;pnum=0 \
66 file://glibc23-ctype-compat.patch;patch=1;pnum=1 \
67 file://glibc23-hppa-Rminkernel.patch;patch=1;pnum=0 \
68 file://glibc23-function-compat.patch;patch=1;pnum=1 \
69 file://glibc23-errno.patch;patch=1;pnum=1 \
70 file://glibc23-asserth-decls.patch;patch=1;pnum=0 \
71 file://alpha-pic.patch;patch=1;pnum=0 \
72 file://glibc23-cmov.patch;patch=1;pnum=1 \
73 file://libgcc-compat-all.patch;patch=1;pnum=0 \
74 file://locales-supported.patch;patch=1;pnum=0 \
75 file://libgcc-compat-other.patch;patch=1;pnum=1 \
76 file://s390-tls.patch;patch=1;pnum=0 \
77 file://hurd-enable-ldconfig.patch;patch=1;pnum=1 \
78 file://30_glibc232-base.patch;patch=1;pnum=0 \
79 file://sparcv8-target.patch;patch=1;pnum=0 \
80 file://50_glibc232-arm-dwarf2-buildfix.patch;patch=1;pnum=0 \
81 file://50_glibc232-m68k-dwarf2-buildfix.patch;patch=1;pnum=1 \
82 file://arm-output-format.patch;patch=1;pnum=0 \
83 file://pthread-cleanup.patch;patch=1;pnum=0 \
84 file://glibc-${PV}-ldconfig-tls.patch;patch=1;pnum=1 \
85 file://glibc23-mips-msq.patch;patch=1;pnum=0 \
86 file://glibc23-libio-compat.patch;patch=1;pnum=1 \
87 file://80_glibc232-locales-nb_NO-fix.patch;patch=1;pnum=0 \
88 file://ldso-disable-hwcap.patch;patch=1;pnum=1 \
89 file://11_shlib-lds.patch;patch=1;pnum=1 \
90 file://glibc23-version-sanity.patch;patch=1;pnum=1 \
91 file://glibc23-sse-oldkernel.patch;patch=1;pnum=1 \
92 file://glibc23-sparc-pread64.patch;patch=1;pnum=1 \
93 file://glibc23-powerpc-sigcontext.patch;patch=1;pnum=1 \
94 file://hppa-syscall.patch;patch=1;pnum=0 \
95 file://glibc23-errno-hack.patch;patch=1;pnum=1 \
96 file://90_glibc232-statvfs.patch;patch=1;pnum=0 \
97 file://90_glibc232-timezones.patch;patch=1;pnum=0 \
98 file://arm-memcpy.patch;patch=1;pnum=0 \
99 file://arm-longlong.patch;patch=1;pnum=0 \
100 file://arm-machine-gmon.patch;patch=1;pnum=0 \
101 file://dyn-ldconfig.diff;patch=1;pnum=0 \
102 file://glibc232-gcc34-i386-fixup-attribute.patch;patch=1;pnum=1 \
103 file://glibc232-gcc34-no-unit-at-a-time.patch;patch=1;pnum=1 \
104 file://etc/ld.so.conf \
105 file://generate-supported.mk"
107 SRC_URI_append_mtx-1 = " file://mips-abio32.patch;patch=1 \
108 file://allow-gcc.patch;patch=1 "
109 SRC_URI_append_mtx-2 = " file://mips-abio32.patch;patch=1 \
110 file://allow-gcc.patch;patch=1 "
112 S = "${WORKDIR}/glibc-${PV}"
113 B = "${WORKDIR}/build-${TARGET_SYS}"
115 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
116 --without-cvs --disable-profile --disable-debug --without-gd \
117 --enable-clocale=gnu \
118 --enable-add-ons=${GLIBC_ADDONS} \
119 --with-headers=${STAGING_INCDIR} \
120 ${GLIBC_EXTRA_OECONF}"
122 EXTRA_OECONF += "${@get_glibc_fpu_setting(bb, d)}"
124 glibc_do_unpack () {
125 mv "${WORKDIR}/linuxthreads" "${WORKDIR}/linuxthreads_db" "${S}/"
128 python do_unpack () {
129 bb.build.exec_func('base_do_unpack', d)
130 bb.build.exec_func('glibc_do_unpack', d)
133 do_configure () {
134 # override this function to avoid the autoconf/automake/aclocal/autoheader
135 # calls for now
136 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
137 # version check and doesn't really help with anything
138 if [ -z "`which rpcgen`" ]; then
139 echo "rpcgen not found. Install glibc-devel."
140 exit 1
142 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
143 CPPFLAGS="" oe_runconf
146 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
147 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
148 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
150 do_compile () {
151 # this really is arm specific
152 touch ${S}/sysdeps/arm/framestate.c
153 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
154 unset LDFLAGS
155 base_do_compile
157 cd ${S}/sunrpc/rpcsvc
158 for r in ${rpcsvc}; do
159 h=`echo $r|sed -e's,\.x$,.h,'`
160 rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
161 done
165 require glibc-stage.inc
167 require glibc-package.bbclass