Add bwm-ng 0.6: lightweight network and disk bandwidth monitor
[openembedded.git] / recipes / freesmartphone / fsod_git.bb
blobc0af2cace3b02a37d7e004c229ec96f9863f5c69
1 DESCRIPTION = "The C/Vala implementation of the freesmartphone.org framework APIs"
2 HOMEPAGE = "http://www.freesmartphone.org/"
3 AUTHOR = "Sudharshan S"
4 SECTION = "console/network"
5 DEPENDS = "dbus dbus-glib libnl vala-native"
6 # for pygobject-codegen
7 DEPENDS += "python-pygtk"
8 LICENSE = "LGPL"
9 PV = "0.1+gitr${SRCREV}"
10 PR = "r1"
12 inherit autotools pkgconfig update-rc.d distutils-base
14 EXTRA_OECONF = "--enable-python --with-python-includes=${STAGING_INCDIR}/.."
16 INITSCRIPT_NAME = "fsod"
17 INITSCRIPT_PARAMS = "defaults 21"
19 SRC_URI = "\
20 ${FREESMARTPHONE_GIT}/openmoko-gsoc2008.git;protocol=git;branch=master \
21 file://autofoo.patch;patch=1 \
22 # file://fsod \
24 S = "${WORKDIR}/git/fsod"
26 do_install_append() {
27 # install -d ${D}${sysconfdir}/init.d
28 # install -m 0755 ${WORKDIR}/fsod ${D}${sysconfdir}/init.d/
31 RCONFLICTS_${PN} = "frameworkd"
32 RREPLACES_${PN} = "frameworkd"
34 FILES_${PN} += "${sysconfdir} ${datadir}"
35 FILES_${PN}-dbg += "\
36 ${bindir}/.debug \
37 ${libdir}/fsod/subsystems/.debug \
38 ${libdir}/fsod/subsystems/*/.debug \