Add bwm-ng 0.6: lightweight network and disk bandwidth monitor
[openembedded.git] / recipes / flnx / flnx_0.18.bb
blob6f84247404d336c6b521d73cbcf355bdd7c0b161
1 SECTION = "x11/libs"
2 DEPENDS = "microwindows"
3 RDEPENDS = "microwindows"
4 DESCRIPTION = "fltk library for microwindows."
5 SRC_URI = "ftp://ftp.microwindows.org/pub/microwindows/flnx/flnx-${PV}-tar.gz \
6 file://gcc3.patch;patch=1"
7 S = "${WORKDIR}/flnx"
8 LICENSE = "LGPL"
10 inherit autotools
12 EXTRA_OECONF = "--with-microwin=${STAGING_LIBDIR}/.."
14 python do_fetch () {
15 import os
16 bb.build.exec_func("base_do_fetch", d)
17 if os.access(bb.data.expand("${DL_DIR}/flnx-${PV}-tar.gz", d), os.R_OK):
18 os.rename(bb.data.expand("${DL_DIR}/flnx-${PV}-tar.gz", d), bb.data.expand("${DL_DIR}/flnx-${PV}.tar.gz", d))
21 python do_unpack () {
22 src_uri = bb.data.getVar("SRC_URI", d)
23 src_uri = src_uri.replace("-tar", ".tar")
24 bb.data.setVar("SRC_URI", src_uri, d)
25 bb.build.exec_func("base_do_unpack", d)
28 do_install () {
29 oe_runmake "bindir=${D}${bindir}" \
30 "libdir=${D}${libdir}" \
31 "includedir=${D}${includedir}" install