opkg: use INC_PR.
[openembedded.git] / recipes / opkg / opkg_svn.bb
blob676a8cb499b2a9a43180b175e4db065854debde9
1 require opkg.inc
3 PR = "${INC_PR}"
5 PACKAGES =+ "libopkg-dev libopkg"
7 FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
8 FILES_libopkg = "${libdir}/*.so.*"
9 # not happens automatically for opkg-nogpg:
10 FILES_${PN} += "${datadir}/opkg/intercept"
12 # Define a variable to allow distros to run configure earlier.
13 # (for example, to enable loading of ethernet kernel modules before networking starts)
14 OPKG_INIT_POSITION = "98"
15 OPKG_INIT_POSITION_slugos = "41"
17 pkg_postinst_${PN} () {
18 update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
21 pkg_postrm_${PN} () {
22 update-alternatives --remove opkg ${bindir}/opkg-cl