gdk-pixbuf-csource-native (2.12.11): Switch to FILESPATHPKG
[openembedded.git] / recipes / ndisc6 / ndisc6_0.6.7.bb
blob7489947f1e692feffb17a4309e1db9a817cbc9b8
1 SECTION = "console/network"
2 DESCRIPTION = "This package includes some useful diagnostics tools for \
3 IPv6 networks, including ndisc6, rdisc6, tcptraceroute6 and traceroute6."
4 SECTION = "console/network"
5 HOMEPAGE = "http://www.simphalempin.com/dev/ndisc6/"
6 LICENSE = "GPL"
7 PR = "r0"
9 # The tcptraceroute6 and tracert6 commands depend on rltraceroute6 to
10 # perform the actual trace operation.
11 RDEPENDS_${PN}-tcptraceroute6 = "${PN}-rltraceroute6"
12 RDEPENDS_${PN}-tracert6 = "${PN}-rltraceroute6"
14 SRC_URI = "http://www.remlab.net/files/ndisc6/ndisc6-${PV}.tar.bz2 \
15 file://autoconf-older-version.patch \
16 file://acinclude.m4"
18 inherit autotools
20 # Split into seperate packages since we normal don't want them all
21 # The main package is left empty and therefore not created.
22 PACKAGES += "${PN}-ndisc6 ${PN}-tcpspray6 ${PN}-rdisc6 \
23 ${PN}-tcptraceroute6 ${PN}-rltraceroute6 ${PN}-tracert6"
24 FILES_${PN} = ""
25 FILES_${PN}-ndisc6 = "${bindir}/ndisc6"
26 FILES_${PN}-tcpspray6 = "${bindir}/tcpspray6"
27 FILES_${PN}-rdisc6 = "${bindir}/rdisc6"
28 FILES_${PN}-tcptraceroute6 = "${bindir}/tcptraceroute6"
29 FILES_${PN}-rltraceroute6 = "${bindir}/rltraceroute6"
30 FILES_${PN}-tracert6 = "${bindir}/tracert6"
32 DESCRIPTION_${PN}-ndisc6 = "ICMPv6 Neighbor Discovery tool. \
33 Performs IPv6 neighbor discovery in userland. Replaces arping from the \
34 IPv4 world."
35 DESCRIPTION_${PN}-rdisc6 = "ICMPv6 Router Discovery tool. \
36 Queries IPv6 routers on the network for advertised prefixes. Can be used \
37 to detect rogue IPv6 routers, monitor legitimate IPv6 routers."
38 DESCRITPION_${PN}-tcpspray6 = "Performs bandwidth measurements of TCP \
39 sessions between the local system and a remote echo server in either IPv6 \
40 or IPv4."
44 # Add some macros from the autoconf 2.60 which to let us build with
45 # autoconf 2.59. This can be removed when/if we update to autoconf
46 # 2.60
47 do_configure_prepend() {
48 cp ${WORKDIR}/acinclude.m4 ${S}
52 # Enable SUID bit for applications that need it
53 pkg_postinst_${PN}-rltraceroute6 () {
54 chmod 4555 ${bindir}/rltraceroute6
56 pkg_postinst_${PN}-ndisc6 () {
57 chmod 4555 ${bindir}/ndisc6
59 pkg_postinst_${PN}-rdisc6 () {
60 chmod 4555 ${bindir}/rdisc6
63 SRC_URI[md5sum] = "77f4154d78304e87698d6da4f5f9ff86"
64 SRC_URI[sha256sum] = "0b60f1101d49f99111232eb6034ec851a46434bf90a056fd087b4a62451ec9ed"