1 # ECJ as a bootstrap compiler is a drop
-in replacement
for Sun's javac. It offers no more
2 #
and no less features.
4 # This variant runs on the initial
(not Java5
-compatible runtime
).
6 DESCRIPTION
= "JDT Core Batch Compiler - Bootstrap variant"
7 HOMEPAGE
= "http://www.eclipse.org/"
10 DEPENDS
= "libecj-bootstrap"
14 SRC_URI
= "file://ecj.in"
16 NATIVE_INSTALL_WORKS
= "1"
22 JAR
= "ecj-bootstrap.jar"
25 # Create the start script
26 echo
"#!/bin/sh" > ecj
-initial
27 echo
"ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj
-initial
28 echo
"RUNTIME=java-initial" >> ecj
-initial
29 cat ecj.in
>> ecj
-initial
33 install
-d $
{D
}$
{bindir
}
34 install
-m
755 $
{S
}/ecj
-initial $
{D
}$
{bindir
}