Fix Angstrom OVERRIDES settings
[openembedded.git] / recipes / prelink / prelink_20061027.bb
blob552117b5484a95511ae3c491034051b54948141d
1 SECTION = "devel"
2 DEPENDS = "elfutils"
3 DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
4 and executables, so that far fewer relocations need to be resolved at \
5 runtime and thus programs come up faster."
6 LICENSE = "GPL"
7 PR = "r6"
9 SRC_URI = "${DEBIAN_MIRROR}/main/p/prelink/prelink_0.0.${PV}.orig.tar.gz \
10 file://prelink.conf \
11 file://prelink.cron.daily \
12 file://prelink.default"
14 TARGET_OS_ORIG := "${TARGET_OS}"
15 OVERRIDES_prepend = "${TARGET_OS_ORIG}:"
16 SRC_URI_append_linux-gnueabi = " file://arm_eabi.patch"
18 S = "${WORKDIR}/prelink-0.0.${PV}"
20 EXTRA_OECONF = "--disable-64bit"
22 inherit autotools
24 do_install_append () {
25 install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
26 install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf
27 install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink
28 install -m 0644 ${WORKDIR}/prelink.default ${D}${sysconfdir}/default/prelink
31 pkg_postinst_prelink() {
32 #!/bin/sh
34 if [ "x$D" != "x" ]; then
35 exit 1
38 . ${sysconfdir}/cron.daily/prelink
41 pkg_prerm_prelink() {
42 #!/bin/sh
44 if [ -f ${sysconfdir}/prelink.cache ]; then
45 prelink -au
46 rm -f ${sysconfdir}/prelink.cache
51 SRC_URI[md5sum] = "9b01aae72da2bb262f29392597847545"
52 SRC_URI[sha256sum] = "e70697c0c23da6b82b330c7db41537ee00dd770da87c92591682f486ab8d1752"