Fix Angstrom OVERRIDES settings
[openembedded.git] / recipes / gphoto2 / libgphoto2_2.4.8.bb
blobc0f6bc553f2f1ca2cdac8a842a1271a864f4bc4e
1 DESCRIPTION = "libgphoto2 allows you to access digital cameras"
2 SECTION = "libs"
3 LICENSE = "GPL"
4 DEPENDS = "libtool jpeg virtual/libusb0 libexif"
6 # The .fdi and .rules files were generated with:
7 # libgphoto2-2.4.7/packaging/generic$ qemu-arm -s 1048576 -r 2.6.24 -L /OE/angstrom-dev/staging/armv5te-angstrom-linux-gnueabi/ .libs/print-camera-list
8 # They are release specific, so please regen when adding new releases
10 SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2;name=libgphoto2 \
11 file://10-camera-libgphoto2-device.fdi \
12 file://10-camera-libgphoto2.fdi \
13 file://90-libgphoto2.rules \
16 SRC_URI[libgphoto2.md5sum] = "7753f17dff15702466337aab05209a71"
17 SRC_URI[libgphoto2.sha256sum] = "69d7e0723b40e8a0c4fa897b96f6aecb5ae5548c3cce98c48e37b70623d9ffc3"
19 inherit autotools pkgconfig lib_package
21 OE_LT_RPATH_ALLOW=":${libdir}:"
22 OE_LT_RPATH_ALLOW[export]="1"
24 EXTRA_OECONF = " --with-drivers=all udevscriptdir=/lib/udev ac_cv_lib_ltdl_lt_dlcaller_register=yes"
26 do_configure_append() {
27 cd ${S}/libgphoto2_port/
28 autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths
29 cd ${S}
32 do_install_append() {
33 install -d ${D}${datadir}/hal/fdi/information/20thirdparty
34 install -m 0644 ${WORKDIR}/*.fdi ${D}${datadir}/hal/fdi/information/20thirdparty/
36 install -d ${D}${sysconfdir}/udev/rules.d/
37 install -m 0755 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/
40 PACKAGES =+ "libgphotoport libgphoto2-camlibs"
41 FILES_libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*"
42 RDEPENDS_${PN} = "libgphoto2-camlibs"
44 FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*"
46 FILES_${PN} += "${libdir}/udev/* ${datadir}/hal"
47 FILES_${PN}-dbg += "${libdir}/*/*/.debug"