task-fso2-compliance: add fsoaudiod as dependency
[openembedded.git] / recipes / shr / shr-launcher_svn.bb
blob457db6789ab4081f2fbcbe9f792c8f28719018cf
1 DESCRIPTION = "shr-launcher is a home app/launcher for openmoko phones"
2 HOMEPAGE = "http://code.google.com/p/shr-launcher/"
3 AUTHOR = "cchandel"
4 LICENSE = "GPLv2"
5 SECTION = "e/apps"
6 DEPENDS = "elementary eina edbus"
7 SRCREV = "105"
8 PV = "0.0.1+svnr${SRCPV}"
9 PR = "r12"
11 SRC_URI = "svn://shr-launcher.googlecode.com/svn;module=trunk;proto=http \
12 file://depends.eina.patch"
14 S = "${WORKDIR}/trunk"
16 inherit autotools
18 do_install_append() {
19 install -d "${D}/${datadir}/pixmaps"
20 install -m 0644 "${S}/resources/launcher.png" "${D}/${datadir}/pixmaps"
21 install -d "${D}/${datadir}/applications"
22 install -m 0644 "${S}/resources/launcher.desktop" "${D}/${datadir}/applications"
23 install -d "${D}/${datadir}/launcher"
24 install -m 0644 "${S}/resources/launcher.edj" "${D}/${datadir}/launcher"
25 for ico in "${S}/resources/"*.png; do
26 if [ "$(basename $ico)" != "launcher.png" ]; then
27 install -m 0644 $ico "${D}/${datadir}/launcher"
29 done
32 FILES_${PN} += "/usr/share/launcher/* /usr/share/applications/* /usr/share/pixmaps/*"