task-fso2-compliance: add fsoaudiod as dependency
[openembedded.git] / recipes / shr / libphone-ui-shr_git.bb
blobe13e90728239d30e6584cd9b2c3a3ab1bc4e4f19
1 DESCRIPTION = "SHR default module for the Phone UI daemon"
2 SECTION = "e/apps"
3 DEPENDS += " libphone-ui evas ecore edje edje-native elementary"
4 SRCREV = "e50e9927fac05664bf1d6b1e0d3a953484038495"
5 PE = "1"
6 PV = "0.0.1+gitr${SRCPV}"
7 PR = "r3"
9 SRC_URI = "git://git.shr-project.org/repo/libphone-ui-shr.git;protocol=http;branch=master"
10 S = "${WORKDIR}/git"
12 inherit pkgconfig autotools gettext
14 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc"
17 do_configure_prepend() {
18 autopoint --force
21 FILES_${PN} += "${libdir}/phoneui/modules/shr.so"
22 FILES_${PN}-dev += "${libdir}/phoneui/modules/*.la"
23 FILES_${PN}-dbg += "${libdir}/phoneui/modules/.debug"
24 FILES_${PN}-static += "${libdir}/phoneui/modules/*.a"