1 DESCRIPTION
= "A minimal version of the Mozilla web browser for mobile devices"
2 SECTION
= "x11/network"
3 LICENSE
= "MPL GPL LGPL"
4 HOMEPAGE
= "http://www.mozilla.org/projects/minimo/"
7 DEPENDS
= "libxrender libxt libxft fontconfig freetype libidl dbus-glib pango atk gtk+ libidl-native zip-native"
9 CVSSVR
="cvs-mirror.mozilla.org"
10 BRTAG
= "MOZILLA_1_8_BRANCH"
11 #SRCDATE_minimo ?
= "20050401"
14 PV
= "0.02+cvs${MOZDATE}"
18 SRC_URI
= "cvs://anonymous@${CVSSVR}/cvsroot;module=mozilla;tag=${BRTAG};date=${MOZDATE} \
20 file://bug-322806.diff \
21 file://mozconfig file://minimo \
22 file://eabi-fix.patch \
23 file://eabi-fix2.patch \
24 file://eabi-fix3.patch \
25 file://minimo-components-ssr-only.patch \
26 file://minimo-disable-mode-switch.patch \
27 file://minimo.desktop file://minimo.png"
31 S
= "${WORKDIR}/mozilla"
33 export MOZCONFIG
= "${WORKDIR}/mozconfig"
35 export CROSS_COMPILE
="1"
36 export ac_cv_prog_HOST_CC
="${BUILD_CC}"
37 export ac_cv_prog_HOST_CFLAGS
="${BUILD_CFLAGS}"
38 export ac_cv_prog_HOST_CXX
="${BUILD_CXX}"
39 export ac_cv_prog_HOST_CXXFLAGS
="${BUILD_CXXFLAGS}"
40 export HOST_LIBIDL_CONFIG
= "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
42 mozdir
="${libdir}/mozilla-minimo"
44 EXTRA_OECONF
+= "--build=${BUILD_SYS} --host=${BUILD_SYS} --target=${TARGET_SYS} "
48 oe_runmake
-f client.mk CONFIGURE_ARGS
="${EXTRA_OECONF}" configure
49 sed
-i s
:$
{TARGET_PREFIX
}strip
:echo
:g config
/autoconf.mk
54 oe_runmake
-f client.mk build
60 install
-d $
{D
}$
{bindir
}
61 install
-m
0755 minimo $
{D
}$
{bindir
}
63 install
-d $
{D
}$
{datadir
}/applications
64 install
-m
0644 minimo.desktop $
{D
}$
{datadir
}/applications
66 install
-d $
{D
}/$
{datadir
}/pixmaps
67 install
-m
0644 minimo.png $
{D
}$
{datadir
}/pixmaps
71 .
/minimo
/config
/linux_package.sh $
{S
} $
{S
}/minimo
/config
75 install
-d $
{D
}$
{mozdir
}
76 install
-m
0755 minimo $
{D
}$
{mozdir
}
77 install
-m
0755 libfreebl3.so $
{D
}$
{mozdir
}
78 install
-m
0755 libnspr4.so $
{D
}$
{mozdir
}
79 install
-m
0755 libnss3.so $
{D
}$
{mozdir
}
80 install
-m
0755 libnssckbi.so $
{D
}$
{mozdir
}
81 install
-m
0755 libplc4.so $
{D
}$
{mozdir
}
82 install
-m
0755 libplds4.so $
{D
}$
{mozdir
}
83 install
-m
0755 libsmime3.so $
{D
}$
{mozdir
}
84 install
-m
0755 libsoftokn3.so $
{D
}$
{mozdir
}
85 install
-m
0755 libssl3.so $
{D
}$
{mozdir
}
87 install
-d $
{D
}$
{mozdir
}/chrome
88 install
-m
0644 chrome
/classic.jar $
{D
}$
{mozdir
}/chrome
89 install
-m
0644 chrome
/classic.manifest $
{D
}$
{mozdir
}/chrome
90 install
-m
0644 chrome
/en
-US.jar $
{D
}$
{mozdir
}/chrome
91 install
-m
0644 chrome
/en
-US.manifest $
{D
}$
{mozdir
}/chrome
92 install
-m
0644 chrome
/minimo
-skin
-vga.jar $
{D
}$
{mozdir
}/chrome
93 install
-m
0644 chrome
/minimo
-skin
-vga.manifest $
{D
}$
{mozdir
}/chrome
94 install
-m
0644 chrome
/minimo
-skin.jar $
{D
}$
{mozdir
}/chrome
95 install
-m
0644 chrome
/minimo
-skin.manifest $
{D
}$
{mozdir
}/chrome
96 install
-m
0644 chrome
/minimo.jar $
{D
}$
{mozdir
}/chrome
97 install
-m
0644 chrome
/minimo.manifest $
{D
}$
{mozdir
}/chrome
98 install
-m
0644 chrome
/pippki.jar $
{D
}$
{mozdir
}/chrome
99 install
-m
0644 chrome
/pippki.manifest $
{D
}$
{mozdir
}/chrome
100 install
-m
0644 chrome
/toolkit.jar $
{D
}$
{mozdir
}/chrome
101 install
-m
0644 chrome
/toolkit.manifest $
{D
}$
{mozdir
}/chrome
103 install
-d $
{D
}$
{mozdir
}/components
104 install
-m
0644 components
/all.xpt $
{D
}$
{mozdir
}/components
105 install
-m
0644 components
/nsHelperAppDlg.js $
{D
}$
{mozdir
}/components
106 install
-m
0644 components
/nsProgressDialog.js $
{D
}$
{mozdir
}/components
108 install
-d $
{D
}$
{mozdir
}/greprefs
109 install
-m
0644 greprefs
/all.js $
{D
}$
{mozdir
}/greprefs
110 install
-m
0644 greprefs
/security
-prefs.js $
{D
}$
{mozdir
}/greprefs
112 install
-d $
{D
}$
{mozdir
}/res
113 install
-m
0644 res
/forms.css $
{D
}$
{mozdir
}/res
114 install
-m
0644 res
/html.css $
{D
}$
{mozdir
}/res
115 install
-m
0644 res
/quirk.css $
{D
}$
{mozdir
}/res
116 install
-m
0644 res
/ua.css $
{D
}$
{mozdir
}/res
117 install
-m
0644 res
/arrow.gif $
{D
}$
{mozdir
}/res
118 install
-m
0644 res
/arrowd.gif $
{D
}$
{mozdir
}/res
119 install
-m
0644 res
/broken
-image.gif $
{D
}$
{mozdir
}/res
120 install
-m
0644 res
/loading
-image.gif $
{D
}$
{mozdir
}/res
121 install
-m
0644 res
/charsetData.properties $
{D
}$
{mozdir
}/res
122 install
-m
0644 res
/charsetalias.properties $
{D
}$
{mozdir
}/res
123 install
-m
0644 res
/langGroups.properties $
{D
}$
{mozdir
}/res
124 install
-m
0644 res
/language.properties $
{D
}$
{mozdir
}/res
125 install
-m
0644 res
/unixcharset.properties $
{D
}$
{mozdir
}/res
127 install
-d $
{D
}$
{mozdir
}/res
/dtd
128 install
-m
0644 res
/dtd
/xhtml11.dtd $
{D
}$
{mozdir
}/res
/dtd
130 install
-d $
{D
}$
{mozdir
}/res
/entityTables
131 install
-m
0644 res
/entityTables
/html40Latin1.properties $
{D
}$
{mozdir
}/res
/entityTables
132 install
-m
0644 res
/entityTables
/html40Special.properties $
{D
}$
{mozdir
}/res
/entityTables
133 install
-m
0644 res
/entityTables
/html40Symbols.properties $
{D
}$
{mozdir
}/res
/entityTables
134 install
-m
0644 res
/entityTables
/htmlEntityVersions.properties $
{D
}$
{mozdir
}/res
/entityTables
135 install
-m
0644 res
/entityTables
/transliterate.properties $
{D
}$
{mozdir
}/res
/entityTables
137 install
-d $
{D
}$
{mozdir
}/res
/fonts
138 install
-m
0644 res
/fonts
/fontEncoding.properties $
{D
}$
{mozdir
}/res
/fonts
139 install
-m
0644 res
/fonts
/pangoFontEncoding.properties $
{D
}$
{mozdir
}/res
/fonts
141 install
-d $
{D
}$
{mozdir
}/res
/html
142 install
-m
0644 res
/html
/gopher
-audio.gif $
{D
}$
{mozdir
}/res
/html
143 install
-m
0644 res
/html
/gopher
-binary.gif $
{D
}$
{mozdir
}/res
/html
144 install
-m
0644 res
/html
/gopher
-find.gif $
{D
}$
{mozdir
}/res
/html
145 install
-m
0644 res
/html
/gopher
-image.gif $
{D
}$
{mozdir
}/res
/html
146 install
-m
0644 res
/html
/gopher
-menu.gif $
{D
}$
{mozdir
}/res
/html
147 install
-m
0644 res
/html
/gopher
-movie.gif $
{D
}$
{mozdir
}/res
/html
148 install
-m
0644 res
/html
/gopher
-sound.gif $
{D
}$
{mozdir
}/res
/html
149 install
-m
0644 res
/html
/gopher
-telnet.gif $
{D
}$
{mozdir
}/res
/html
150 install
-m
0644 res
/html
/gopher
-text.gif $
{D
}$
{mozdir
}/res
/html
151 install
-m
0644 res
/html
/gopher
-unknown.gif $
{D
}$
{mozdir
}/res
/html
154 # We don't build XUL as system shared lib
, so we can mark all libs as private
155 PRIVATE_LIBS
= "libnssckbi.so \
173 libbrowserdirprovider.so \
181 libunixprintplugin.so \
184 FILES_$
{PN
}-dbg
+= "${libdir}/mozilla-minimo/.debug*"
185 FILES_$
{PN
} += "${mozdir}"