task-fso2-compliance: add fsoaudiod as dependency
[openembedded.git] / recipes / gstreamer / gst-ffmpeg_0.10.2.bb
blob5164bbdfee444f1d1ba3f2b03ddecbb2ee5ab2dd
1 DESCRIPTION = "FFmpeg-based GStreamer plug-in"
2 SECTION = "multimedia"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5 HOMEPAGE = "http://www.gstreamer.net/"
6 DEPENDS = "gstreamer gst-plugins-base zlib"
7 PR = "r2"
9 inherit autotools pkgconfig
11 SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2 \
12 file://armv5.patch \
13 file://autotools.patch \
16 FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
17 FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
18 FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
20 EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \
21 --disable-vorbis --disable-vorbistest --disable-encoders \
22 --disable-v4l --disable-audio-oss --disable-dv1394 \
23 --disable-vhook --disable-ffmpeg --disable-ffserver \
24 --enable-pp --disable-decoder-vorbis"
26 # We do this because the install program is called with -s which causes it to
27 # call "strip" and it then mangles cross compiled stuff..
28 PATH_prepend := "${TOOLCHAIN_PATH}/${TARGET_SYS}/bin:"
30 # Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
31 CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
34 SRC_URI[md5sum] = "3c7fb1cd1308b1972a76b86bb29fc890"
35 SRC_URI[sha256sum] = "ffa7c89bccab5d1be53b6fcedcf7a5c071d585cf522fee5864add05d350f5842"