repo.or.cz
/
openembedded.git
/
blob
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
log
|
graphiclog1
|
graphiclog2
|
commit
|
commitdiff
|
tree
|
refs
|
edit
|
fork
blame
|
history
|
raw
|
HEAD
xorg-xserver: obsolete old versions
[openembedded.git]
/
classes
/
typecheck.bbclass
blob
646cd4eed2fd5257bfeb571814a50b35a14528e9
1
# Check types of bitbake configuration variables
2
#
3
# See oe.types for details.
4
5
python check_types() {
6
import oe.types
7
if isinstance(e, bb.event.ConfigParsed):
8
for key in e.data.keys():
9
if e.data.getVarFlag(key, "type"):
10
oe.types.value(key, e.data)
11
}
12
addhandler check_types