1 PACKAGESTRIPFUNCS += "do_strip_modules"
3 # inherit to get get_kernelmajorversion();
4 inherit linux-kernel-base
6 # may be inherited by kernel.bbclass which sets KERNEL_MAJOR_VERSION
7 KERNEL_MAJOR_VERSION ?= "${@get_kernelmajorversion('${KERNEL_VERSION}')}"
10 if test -e ${PKGD}/lib/modules; then
11 if [ "${KERNEL_MAJOR_VERSION}" = "2.6" ]; then
12 modules="`find ${PKGD}/lib/modules -name \*.ko`"
14 modules="`find ${PKGD}/lib/modules -name \*.o`"
16 if [ -n "$modules" ]; then
17 for module in $modules ; do
18 if ! [ -d "$module" ] ; then
19 ${STRIP} -v -g $module