vdr: fix dependency for libintl
[openembedded.git] / recipes / vlc / vlc_0.9.8a.bb
blob6127579b67180439fffae8cb62370366cd4c0373
1 # This recipe packages vlc as a library as well, so qt4 dependencies
2 # can be avoided when ony the library is installed.
3 # Would be cool if when newer vlc is added to OE and older ones are phased
4 # out that could be made the default.
6 require vlc.inc
8 PR = "r3"
10 # ffmpeg from git (library version => 52) is required
11 # libtool-native must be >= 2.2.4
12 DEPENDS += "libdvdcss libdvdread"
14 EXTRA_OECONF += "\
15 --enable-dvdread \
18 LEAD_SONAME = "libvlc.so.2"
20 PACKAGES =+ "libvlc-dbg libvlc-dev libvlc"
22 FILES_libvlc-dev = "${libdir}/lib*.so"
24 FILES_libvlc-dbg = "\
25 ${libdir}/.debug \
26 ${libdir}/vlc/meta_engine/.debug \
27 ${libdir}/vlc/audio_filter/.debug ${libdir}/vlc/audio_output/.debug \
28 ${libdir}/vlc/demux/.debug ${libdir}/vlc/control/.debug \
29 ${libdir}/vlc/gui/.debug ${libdir}/vlc/packetizer/.debug \
30 ${libdir}/vlc/audio_mixer/.debug ${libdir}/vlc/stream_out/.debug \
31 ${libdir}/vlc/mux/.debug ${libdir}/vlc/access/.debug \
32 ${libdir}/vlc/visualization/.debug ${libdir}/vlc/access_filter/.debug \
33 ${libdir}/vlc/access_output/.debug ${libdir}/vlc/video_output/.debug \
34 ${libdir}/vlc/services_discovery/.debug ${libdir}/vlc/video_chroma/.debug \
35 ${libdir}/vlc/video_codec/.debug ${libdir}/vlc/video_filter/.debug \
36 ${libdir}/vlc/misc/.debug ${libdir}/vlc/codec/.debug \
39 FILES_libvlc = "${libdir}/lib*.so.*"
41 FILES_${PN} += "${bindir}/vlc \
42 ${datadir}/applications \
43 ${datadir}/vlc/ \
46 FILES_${PN}-dbg += "${libdir}/vlc/*/.debug"