vdr: fix dependency for libintl
[openembedded.git] / recipes / shadow / shadow_4.1.4.2.bb
blob04887a01d1c3544f05813feb3ef4b95d32ccd72c
1 DESCRIPTION = "login/password and account utilities"
2 LICENSE = "GPL"
4 DEPEND = "libpam"
5 RDEPEND = "${DEPEND}"
7 PR = "r5"
9 EXTRA_OECONF += " --enable-shared --enable-static --with-libpam --without-libcrack"
11 inherit autotools
13 HOMEPAGE = "http://pkg-shadow.alioth.debian.org/"
14 SRC_URI = "ftp://pkg-shadow.alioth.debian.org/pub/pkg-shadow/shadow-${PV}.tar.bz2 \
15 file://login_defs_pam.sed \
18 # Additional Policy files for PAM
19 SRC_URI_append = " \
20 file://pam.d/chfn \
21 file://pam.d/chpasswd \
22 file://pam.d/chsh \
23 file://pam.d/login \
24 file://pam.d/newusers \
25 file://pam.d/passwd \
26 file://pam.d/su \
29 S = "${WORKDIR}/shadow-${PV}"
31 CFLAGS_append = " -I../include"
33 do_install_append() {
34 # Ensure that the image has as /var/spool/mail dir so shadow can put mailboxes there if the user
35 # reconfigures Shadow to default (see sed below).
36 install -d ${D}${localstatedir}/spool/mail/
38 install -d ${D}${sysconfdir}/pam.d/
39 install -m 0644 ${WORKDIR}/pam.d/* ${D}${sysconfdir}/pam.d/
41 # Remove defaults that are not used when supporting PAM
42 sed -i -f ${WORKDIR}/login_defs_pam.sed ${D}${sysconfdir}/login.defs
44 # Enable CREATE_HOME by default.
45 sed -i 's/#CREATE_HOME/CREATE_HOME/g' ${D}${sysconfdir}/login.defs
47 # As we are on an embedded system ensure the users mailbox is in ~/ not
48 # /var/spool/mail by default as who knows where or how big /var is.
49 # The system MDA will set this later anyway.
50 sed -i 's/MAIL_DIR/#MAIL_DIR/g' ${D}${sysconfdir}/login.defs
51 sed -i 's/#MAIL_FILE/MAIL_FILE/g' ${D}${sysconfdir}/login.defs