vdr: fix dependency for libintl
[openembedded.git] / recipes / povray / povray_3.6.1.bb
blob107c86cfb87b4ba994f35706c41f6a199caec0a6
1 DESCRIPTION = "The Persistence of Vision Raytracer is a high-quality, totally free tool for creating stunning three-dimensional graphics. "
2 HOMEPAGE = "http://www.povray.org"
3 SECTION = "console/graphics"
4 #Make this a weak assigment to allow branding of the povray binary
5 LICENSE = "povray"
6 DEPENDS = "virtual/libx11 zlib jpeg libpng tiff"
7 RDEPENDS = ""
9 PR = "r2"
11 #We apply a patch that subverts the checks for jpeg, zlib, png and tiff because we know OE has the required versions, but it is still a hack.
12 SRC_URI = "http://www.povray.org/redirect/www.povray.org/ftp/pub/povray/Official/Unix/${P}.tar.bz2 \
13 file://configure-cross-hack.patch;patch=1"
15 inherit autotools pkgconfig
17 PARALLEL_MAKE = ""
19 #autoreconf breaks, so we'll skip that. The added advantage is that the patch to ./configure actually has effect
20 do_configure() {
21 oe_runconf COMPILED_BY="${MAINTAINER}"
24 PACKAGES += "${PN}-scenes ${PN}-ini ${PN}-icons ${PN}-scripts ${PN}-includes"
26 PACKAGE_ARCH_${PN}-doc = "all"
28 PACKAGE_ARCH_${PN}-scenes = "all"
29 FILES_${PN}-scenes = "${datadir}/povray-3.6/scenes"
31 PACKAGE_ARCH_${PN}-ini = "all"
32 FILES_${PN}-ini = "${datadir}/povray-3.6/ini"
34 PACKAGE_ARCH_${PN}-icons = "all"
35 FILES_${PN}-icons = "${datadir}/povray-3.6/icons"
37 PACKAGE_ARCH_${PN}-scripts = "all"
38 FILES_${PN}-scripts = "${datadir}/povray-3.6/scripts"
40 PACKAGE_ARCH_${PN}-includes = "all"
41 FILES_${PN}-includes = "${datadir}/povray-3.6/include"