vdr: fix dependency for libintl
[openembedded.git] / recipes / nylon / nylon-config.bb
blob76f78a97f7fb13639a69b9adc373714ac69efe95
1 DESCRIPTION = "nylon preliminary web configuration interface"
2 SECTION = "base"
3 PRIORITY = "optional"
4 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
5 LICENSE = "closed"
6 DEPENDS = "perl virtual/kernel hostap-daemon busybox"
7 RDEPENDS = "perl perl-module-exporter perl-module-posix perl-module-autoloader perl-module-strict perl-module-xsloader perl-module-data-dumper perl-module-carp perl-module-bytes perl-module-overload perl-module-warnings-register perl-module-warnings kernel-module-aes madwifi-modules hostap-daemon simple-firewall wlan-ng-utils busybox-httpd"
8 CVSDATE = "20051026"
9 PV = "cvs${CVSDATE}"
11 SRC_URI = "http://br1.einfach.org/nylon/stable/sources/nylon-config_gruen.4g__20051026.tar.gz"
12 S = "${WORKDIR}/${PN}"
14 do_install() {
15 (cd ${S}; tar -c --exclude .svn -f - . ) | tar -C ${D} -xpf -
16 # chmod 600 ${D}/etc/certs/stunnel.key
17 chmod a+x ${D}/srv/www/cgi-bin/*
20 pkg_postinst() {
21 #!/bin/sh
22 if test "x$D" != "x"; then
23 exit 1
26 # Create resolv.conf-link to ppp-file
27 rm /etc/resolv.conf
28 ln -s /etc/ppp/resolv.conf /etc/resolv.conf
30 # enable factorydefaults
31 update-rc.d factorydefaults start 90 2 .
33 # "fix" /etc/network/interfaces
34 perl -I /srv/www/cgi-bin -MConfig::IFace -e '$w=new Config::IFace(); $v = $w->read(); $v->{auto} = {0=>"lo",1=>eth0,2=>"wlan0",3=>"wlan1",4=>"ath0",5=>"ath1"}; $w->write($v)'
36 update-rc.d busybox-httpd start 40 2 3 4 5 .
37 /etc/init.d/busybox-httpd restart
40 FILES_${PN} += "/srv"