vdr: fix dependency for libintl
[openembedded.git] / recipes / gnome / gnome-power-manager_2.24.2.bb
blob88153396b0fc51ab6a1b9448a48f5f444cd3cd29
1 LICENSE = "GPLv2"
2 DEPENDS = "gtk+ gnome-keyring libgnome libgnomeui hal dbus libglade \
3 libnotify libwnck cairo libunique gnome-panel gstreamer \
4 xrandr policykit-gnome gnome-doc-utils dbus-glib "
6 inherit gnome
8 EXTRA_OECONF = " --disable-scrollkeeper \
9 --disable-keyring \
10 --x-includes=${STAGING_INCDIR} \
11 --x-libraries=${STAGING_LIBDIR} \
12 --with-dpms-ext=${STAGING_INCDIR}/.. \
13 --enable-compile-warnings=no \
14 ac_cv_header_X11_extensions_dpms_h=yes \
17 do_configure_prepend() {
18 sed -i -e 's: man ::g' ${S}/Makefile.am
21 do_configure_append() {
22 rm config.log
23 # Sigh... --enable-compile-warnings=no doesn't actually turn off -Werror
24 for i in $(find ${S} -name "Makefile") ; do
25 sed -i -e s:-Werror::g $i
26 done
29 PACKAGES =+ "${PN}-applets"
31 FILES_${PN}-applets = "${bindir}/*applet* \
32 ${libdir}/bonobo/servers \
33 ${datadir}/gnome-2.0/ui"
35 FILES_${PN} += "${datadir}/icons \
36 ${datadir}/dbus-1 \
37 ${datadir}/gnome/autostart \
40 FILES_${PN}-doc += "${datadir}/omf \
41 ${datadir}/gnome/help "