vdr: fix dependency for libintl
[openembedded.git] / recipes / bind / bind_9.3.4-P1.bb
blob59d2599a134ef75b506a88ef8135f5230ebdf9c6
1 DESCRIPTION = "ISC Internet Domain Name Server"
2 SECTION = "console/network"
3 HOMEPAGE = "http://www.isc.org/sw/bind/"
4 LICENSE = "BSD"
5 PR = "r0"
7 DEPENDS = "openssl"
9 SRC_URI = "ftp://ftp.isc.org/isc/bind9/9.3.4-P1/bind-9.3.4-P1.tar.gz \
10 file://conf.patch;patch=1 \
11 file://configure.in.patch;patch=1 \
12 file://so_bsdcompat.patch;patch=1 \
15 EXTRA_OECONF = " --enable-ipv6=no --with-randomdev=/dev/random --disable-threads --sysconfdir=/etc/bind --localstatedir=/var --prefix=/usr"
16 inherit autotools update-rc.d
18 INITSCRIPT_NAME = "bind"
19 INITSCRIPT_PARAMS = "defaults"
21 do_install_append() {
22 rm "${D}/usr/bin/nslookup"
23 install -d "${D}/etc/bind"
24 install -d "${D}/etc/init.d"
25 install -m 644 ${S}/conf/* "${D}/etc/bind"
26 install -m 755 "${S}/init.d" "${D}/etc/init.d/bind"
29 CONFFILES_${PN} = " \
30 ${sysconfdir}/bind/named.conf \
31 ${sysconfdir}/bind/named.conf.local \
32 ${sysconfdir}/bind/named.conf.options \
33 ${sysconfdir}/bind/db.0 \
34 ${sysconfdir}/bind/db.127 \
35 ${sysconfdir}/bind/db.empty \
36 ${sysconfdir}/bind/db.local \
37 ${sysconfdir}/bind/db.root \