1 DEPENDS =+ "gettext-native"
2 def gettext_after_parse(d):
4 # Remove the NLS bits if USE_NLS is no.
5 if bb.data.getVar('USE_NLS', d, 1) == 'no':
6 cfg = oe_filter_out('^--(dis|en)able-nls$', bb.data.getVar('EXTRA_OECONF', d, 1) or "", d)
7 cfg += " --disable-nls"
8 depends = bb.data.getVar('DEPENDS', d, 1) or ""
9 bb.data.setVar('DEPENDS', oe_filter_out('^(virtual/libiconv|virtual/libintl)$', depends, d), d)
10 bb.data.setVar('EXTRA_OECONF', cfg, d)
13 gettext_after_parse(d)
16 DEPENDS =+ "gettext-native"
17 EXTRA_OECONF += "--enable-nls"