ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / uclibc / uclibc-initial_0.9.28.bb
blobed290220c3a332de8214004e54c81d33aa5f915a
1 SECTION = "base"
2 require uclibc_${PV}.bb
4 DEPENDS = "linux-libc-headers ncurses-native virtual/${TARGET_PREFIX}gcc-initial"
5 PROVIDES = "virtual/${TARGET_PREFIX}libc-initial"
6 PACKAGES = ""
8 do_install() {
9 # Install initial headers into the cross dir
10 make PREFIX=${D} DEVEL_PREFIX=${prefix}/ RUNTIME_PREFIX=/ \
11 pregen install_dev
13 #install -d ${CROSS_DIR}/${TARGET_SYS}
14 #ln -sf include ${CROSS_DIR}/${TARGET_SYS}/sys-include
16 # This conflicts with the c++ version of this header
17 rm -f ${D}${includedir}/bits/atomicity.h
18 install -d ${D}${libdir}/
19 install -m 644 libc/sysdeps/linux/${TARGET_ARCH}/crt[1in].o ${D}${libdir}/
20 install -m 644 libc/libc.so ${D}${libdir}/
24 do_compile () {
25 make PREFIX=${D} DEVEL_PREFIX=${prefix}/ RUNTIME_PREFIX=/ \
26 libc/sysdeps/linux/${TARGET_ARCH}/crt1.o \
27 libc/sysdeps/linux/${TARGET_ARCH}/crti.o \
28 libc/sysdeps/linux/${TARGET_ARCH}/crtn.o
29 ${CC} -nostdlib -nostartfiles -shared -x c /dev/null \
30 -o lib/libc.so