ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / txdrug / txdrug_0.1.bb
blobbaa9f525cdc57c5c9d16b9025c56626c961ab118
1 DESCRIPTION = "Tx Drug Database"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 DEPENDS = "sqlite"
6 PR = "r3"
8 SRC_URI = "http://teax.sourceforge.net/txdrug-${PV}.tar.gz \
9 file://opt/QtPalmtop"
10 S = "${WORKDIR}/txdrug-tar"
12 inherit palmtop
14 EXTRA_QMAKEVARS_POST += "LIBS+=-lsqlite TARGET=txdrug"
16 do_configure_prepend() {
17 rm -f Makefile && qmake -project
20 do_configure_append() {
21 sed -i "s/\-I\/usr\/include\/sqlite\ //g" Makefile
24 do_install() {
25 install -d ${D}${palmtopdir}
26 cp -Pfr `ls -dp ${WORKDIR}/opt/QtPalmtop/*|grep -v SCCS` ${D}${palmtopdir}/
27 install -D -m 755 txdrug ${D}${palmtopdir}/bin/txdrug
31 SRC_URI[md5sum] = "c867374392559d6e475eeb03f6a81169"
32 SRC_URI[sha256sum] = "ee1044b61fc457ecc6025d06c5b9241994bd19e3d6ce98ae0827842caab00f0f"