ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / sudo / sudo-enable-wheel-group.bb
blobec1de9e7f21c94f4fbf0ce8c897bd48a4ce78038
1 PR = "r1"
3 RDEPENDS_${PN} = "sudo"
5 ALLOW_EMPTY_${PN} = "1"
6 PACKAGE_ARCH = "all"
8 # Edit sudoers to allow the use of the wheel group and non root users to mount/shutdown etc.
9 # Please consider this when using.
11 pkg_postinst() {
12 #!/bin/sh
13 mkdir -p $D${sysconfdir}/
14 touch $D${sysconfdir}/sudoers
15 sed -i /# %wheel/d $D${sysconfdir}/sudoers
16 echo '%wheel ALL=(ALL) ALL' >> $D${sysconfdir}/sudoers
17 sed -i /# %users/d $D${sysconfdir}/sudoers
18 echo '%users ALL=/sbin/mount /cdrom,/sbin/umount /cdrom' >> $D${sysconfdir}/sudoers
19 echo '%users localhost=/sbin/shutdown -h now' >> $D${sysconfdir}/sudoers