ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / qpf-fonts / qpf-qte_3.3.5.bb
blobb4672711f5b02baf03f5ec4d00fff15e38235219
1 require qpf.inc
3 DESCRIPTION = "Qt/Embedded fonts version ${PV}"
4 HOMEPAGE = "http://www.trolltech.com"
5 LICENSE = "GPL QPL"
6 PR = "r6"
8 SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-free-${PV}.tar.bz2"
9 S = "${WORKDIR}/qt-embedded-free-${PV}"
11 do_compile() {
15 do_install() {
16 mkdir -p ${D}${sbindir}
17 mkdir -p ${D}${palmtopdir}/lib/fonts
18 cp -pPR lib/fonts/* ${D}${palmtopdir}/lib/fonts
19 # Delete all other font formats, Qt/E would have a dead slow
20 # application start time if it had to use any other font format
21 # as *.qpf ...
22 find ${D}${palmtopdir}/lib/fonts \
23 -name "*.bdf" \
24 -o -name "*.ttf" \
25 -o -name "*.pfa" \
26 -o -name "*.pfb" | xargs rm
29 PACKAGES = "qte-font-fixed"
30 PROVIDES += "qte-font-fixed"
31 FILES_qte-font-fixed = "${palmtopdir}/lib/fonts/fixed*"
33 PACKAGES += "qte-font-helvetica-small"
34 PROVIDES += "qte-font-helvetica-small"
35 FILES_qte-font-helvetica-small = "${palmtopdir}/lib/fonts/helvetica_80*.qpf \
36 ${palmtopdir}/lib/fonts/helvetica_100*.qpf ${palmtopdir}/lib/fonts/helvetica_120*.qpf"
38 PACKAGES += "qte-font-helvetica-large"
39 PROVIDES += "qte-font-helvetica-large"
40 FILES_qte-font-helvetica-large = "${palmtopdir}/lib/fonts/helvetica_140*.qpf \
41 ${palmtopdir}/lib/fonts/helvetica_180*.qpf ${palmtopdir}/lib/fonts/helvetica_240*.qpf"
43 PACKAGES += "qte-font-smoothtimes"
44 PROVIDES += "qte-font-smoothtimes"
45 FILES_qte-font-smoothtimes = "${palmtopdir}/lib/fonts/smoothtimes*"
47 PACKAGES += "qte-font-smallsmooth"
48 PROVIDES += "qte-font-smallsmooth"
49 FILES_qte-font-smallsmooth = "${palmtopdir}/lib/fonts/smallsmooth*"
51 PACKAGES += "qte-font-unicode"
52 PROVIDES += "qte-font-unicode"
53 FILES_qte-font-unicode = "${palmtopdir}/lib/fonts/unifont*.qpf"
55 PACKAGES += "qte-font-micro"
56 PROVIDES += "qte-font-micro"
57 FILES_qte-font-micro = "${palmtopdir}/lib/fonts/micro*.qpf"
59 SRC_URI[md5sum] = "022d7a3c572b554f3c47b12cae71a8a4"
60 SRC_URI[sha256sum] = "a97656796c0ef8e87dd83e6138bc406e31830d08f9b213e039d8be39ea65c8e4"