ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / openmoko-3rdparty / podboy_svn.bb
blob1cbeb698d24b1fa167c4ea717f8168a543306310
1 DESCRIPTION = "A podcast aggregator/player"
2 HOMEPAGE = "http://code.google.com/p/podboy/"
3 LICENSE = "GPLv3"
4 AUTHOR = "Valéry Febvre <vfebvre@easter-eggs.com>"
5 SECTION = "x11/applications"
6 PRIORITY = "optional"
8 SRCREV = "210"
9 PV = "1.7.2+svnr${SRCPV}"
10 PR = "r3"
12 PACKAGE_ARCH = "all"
14 SRC_URI = "svn://podboy.googlecode.com/svn;module=trunk;proto=http"
15 S = "${WORKDIR}/trunk"
17 inherit distutils
19 FILES_${PN} += "${datadir}/podboy ${datadir}/applications/podboy.desktop ${datadir}/pixmaps/podboy.png"
21 DEPENDS = "edje-native ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugins-ugly', d)}"
22 RDEPENDS_${PN} += "python-compression python-elementary python-gst python-html python-netclient python-netserver python-sqlite3 python-subprocess gst-plugin-alsa gst-plugin-audioconvert gst-plugin-audioresample gst-plugin-bluez ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'gst-plugin-mad', d)} gst-plugin-ogg gst-plugin-volume gst-plugin-vorbis"
24 do_compile_prepend() {
25 ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/data ${S}/data/podboy.edc