ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / openmoko-3rdparty / neomis_svn.bb
blob706261b81326dcf45bfc2cf9a2888024fdf514dd
1 DESCRIPTION = "A computer version of the well-known electronic game named Simon"
2 HOMEPAGE = "http://code.google.com/p/neomis/"
3 LICENSE = "GPLv3"
4 AUTHOR = "Valéry Febvre <vfebvre@easter-eggs.com>"
5 SECTION = "x11/applications"
6 PRIORITY = "optional"
7 DEPENDS = "python-native edje-native"
9 SRCREV = "8"
10 # actually it's 1.0.3 :/ but don't want to downgrade now/bump PE
11 PV = "1.1.0+svnr${SRCPV}"
12 PR = "r2"
14 S = "${WORKDIR}/trunk"
16 PACKAGE_ARCH = "all"
18 SRC_URI = "svn://neomis.googlecode.com/svn;module=trunk;proto=http"
20 inherit distutils
22 do_configure_prepend_shr() {
23 sed -e 's,^Exec=,Exec=/usr/bin/fsoraw -r Display ,g' -i ${S}/data/neomis.desktop
26 FILES_${PN} += "${datadir}/neomis ${datadir}/applications/neomis.desktop ${datadir}/pixmaps"
28 RDEPENDS_${PN} += "python-audio python-pyalsaaudio python-elementary"
30 do_compile_prepend() {
31 ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/data ${S}/data/neomis.edc