ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / netsurf / libnsgif_0.0.2.bb
blob5291169c0dca55163c0de2e743192efbd09c1120
1 DESCRIPTION = "Libnsgif is a decoding library for the GIF image file format"
2 HOMEPAGE = "http://www.netsurf-browser.org/projects/libnsgif/"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 LICENSE = "MIT"
7 PR = "r1"
9 SRC_URI = "http://www.netsurf-browser.org/projects/releases/libnsgif-${PV}-src.tar.gz"
11 inherit pkgconfig
13 EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix} BUILDDIR=build-OE"
15 # NOTE: we're using default buildmode here, which results in building only
16 # static libraries (.a) Not a problem as libnsbmp is only used by Netsurf
17 # at the moment
19 do_stage() {
20 oe_libinstall -a -C build-OE/ libnsgif ${STAGING_LIBDIR}
21 install -m 0644 build-OE/libnsgif.pc ${STAGING_LIBDIR}/pkgconfig
22 install -m 0644 include/*.h ${STAGING_INCDIR}/
25 do_install() {
26 oe_runmake install
29 SRC_URI[md5sum] = "08dd5fc3ea330784f6c1e55c58244749"
30 SRC_URI[sha256sum] = "dcb68be6a49ecc376cfa283d2f1e7eae035c75f99c0934ac80951e1777059617"