ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / lsh / lsh_2.0.4.bb
blob99d53583a5d85abedc99e5e9c56548028814dcc8
1 LICENSE = "GPL"
2 SECTION = "console/network"
3 DESCRIPTION = "lsh is a GNU GPL-licensed implementation of the SSH \
4 (version 2) protocol. It includes a server, a client, and some \
5 utility programs."
6 DEPENDS = "zlib gmp liboop"
8 SRC_URI = "http://www.lysator.liu.se/~nisse/archive/lsh-${PV}.tar.gz;name=src"
9 SRC_URI[src.md5sum] = "621f4442332bb772b92d397d17ccaf02"
10 SRC_URI[src.sha256sum] = "614b9d63e13ad3e162c82b6405d1f67713fc622a8bc11337e72949d613713091"
11 S = "${WORKDIR}/lsh-${PV}"
13 inherit autotools
14 configopts = " --enable-debug-alloc Enable memory allocation sanity checks \
15 --enable-debug-trace Enable tracing support \
16 --enable-gcov Instrument for gcov (requires a modern gcc) \
17 --without-pty Disable pty support \
18 --disable-srp Disable the (experimental) support for SRP \
19 --disable-kerberos Don't support kerberos \
20 --disable-pam Don't support PAM \
21 --disable-datafellows-workarounds \
22 --enable-initgroups-workaround \
23 --disable-tcp-forward Disable tcp forwarding \
24 --disable-x11-forward Disable x11 forwarding (proxy only) \
25 --disable-agent-forward Disable auth-agent forwarding (proxy only) \
26 --disable-ipv6 Disable IPv6 support \
27 --disable-utmp Disable utmp and wtmp support \
28 --without-zlib Don't use zlib compression \
29 --with-tcpwrappers Use tcp-wrappers for filtering connections \
30 --with-sshd1=PROGRAM support fallback to SSH1 daemon \
31 --with-scheme=PROGRAM Use a particular scheme implementation \
32 --without-system-argp Don't use the system's argp \
33 --with-include-path A colon-separated list of directories to search for \
34 --with-lib-path A colon-separated list of directories to search for \
35 --with-x use the X Window System"
36 EXTRA_OECONF = "--disable-srp --disable-kerberos --disable-pam \
37 --without-x"