ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / linux / linux-magicbox_2.6.19.2.bb
blob683defd805bd27315e4051773b09e56430575c64
1 # Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
2 # Released under the MIT license (see packages/COPYING)
3 SECTION = "kernel"
4 DESCRIPTION = "Linux kernel for Magicbox ver 1.1 and 2.0 router boards"
5 LICENSE = "GPLv2"
6 PR = "r3"
7 DEPENDS = "u-boot"
9 COMPATIBLE_MACHINE = "magicbox"
11 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
12 file://001-squashfs.patch \
13 file://002-lzma_decompress.patch \
14 file://003-squashfs_lzma.patch \
15 file://004-extra_optimization.patch \
16 file://006-gcc4_inline_fix.patch \
17 file://007-samsung_flash.patch \
18 file://009-revert_intel_flash_breakage.patch \
19 file://010-disable_old_squashfs_compatibility.patch \
20 file://011-mips_boot.patch \
21 file://012-mips_cpu_tlb.patch \
22 file://050-mtdpart_redboot_partition_truncate.patch \
23 file://060-rootfs_split.patch \
24 file://100-netfilter_layer7_2.8.patch \
25 file://101-netfilter_layer7_pktmatch.patch \
26 file://110-ipp2p_0.8.1rc1.patch \
27 file://120-openswan-2.4.0.kernel-2.6-natt.patch \
28 file://130-netfilter-ipset.patch \
29 file://140-netfilter_time.patch \
30 file://150-netfilter_imq.patch \
31 file://160-netfilter_route.patch \
32 file://170-netfilter_chaostables.patch \
33 file://200-sched_esfq.patch \
34 file://201-multiple_default_gateways.patch \
35 file://202-mips-freestanding.patch \
36 file://204-jffs2_eofdetect.patch \
37 file://207-powerpc_asm_segment_h.patch \
38 file://210-d80211_compat.patch \
39 file://211-no_block2mtd_readahead.patch \
40 file://212-block2mtd_erase_scan.patch \
41 file://510-Yaffs.patch \
42 file://600-x86_lzma.patch \
43 file://700-airprime.patch \
44 file://900-headers_type_and_time.patch \
45 file://901-asm_bitops_include.patch \
46 file://902-darwin_scripts_include.patch \
47 file://903-stddef_include.patch \
48 file://904-ls_time_locale.patch \
49 file://001-magicbox_support.patch \
50 file://002-flash_map.patch \
51 file://100-cf_slot.patch \
53 file://config-magicbox2\
57 S = "${WORKDIR}/linux-${PV}"
59 inherit kernel
62 FILES_kernel-image = "/boot/zImage.elf"
64 export OS = "Linux"
65 ARCH = "ppc"
66 KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
71 do_configure_prepend() {
72 install -m 0644 ${WORKDIR}/config-magicbox2 ${S}/.config
76 do_install_append () {
77 #need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
79 install -d $kerneldir/arch/
80 cp -pPR arch/ppc $kerneldir/arch/
81 cp -pPR arch/powerpc $kerneldir/arch/
83 cp -pPR include/asm-powerpc $kerneldir/include/
84 cp -pPR include/asm-ppc $kerneldir/include/
89 do_install_append () {
90 install -d ${DEPLOY_DIR_IMAGE}
91 install -m 0755 arch/ppc/boot/images/zImage.elf ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
92 install -m 0755 vmlinux ${DEPLOY_DIR_IMAGE}/
93 powerpc${TARGET_VENDOR}-${TARGET_OS}-objcopy -O binary -R .note -R .comment -S ${DEPLOY_DIR_IMAGE}/vmlinux \
94 ${DEPLOY_DIR_IMAGE}/linux.bin
95 gzip -f -9 ${DEPLOY_DIR_IMAGE}/linux.bin
96 cp -pPR ${DEPLOY_DIR_IMAGE}/linux.bin.gz ${DEPLOY_DIR_IMAGE}/linux-${PV}-${MACHINE}-${DATETIME}.bin.gz
97 mkimage -A ppc -O linux -T kernel -C gzip -a 00000000 -e 00000000 -n "magicbox"-${PV} \
98 -d ${DEPLOY_DIR_IMAGE}/linux.bin.gz ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${MACHINE}-${DATETIME}.bin
99 rm ${DEPLOY_DIR_IMAGE}/vmlinux
100 rm ${DEPLOY_DIR_IMAGE}/linux.bin.gz
106 pkg_postinst_kernel () {
107 true
110 pkg_postrm_kernel () {
111 true
116 SRC_URI[md5sum] = "ca0ce8f288e8ae93ac243b568f906bf8"
117 SRC_URI[sha256sum] = "c55c52caa613d1f25718b35811e4614d9712b9e1de56a91aa73c867f351a540b"