ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / linux / linux-h1940_2.6.14-h1940.bb
blob1138c8f1a7c09ce0dcfafcf6d7c9b9a40542ce38
1 DESCRIPTION = "Linux kernel for h1940 devices."
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
5 COMPATIBLE_HOST = "arm.*-linux"
6 COMPATIBLE_MACHINE = "h1940"
8 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.14.tar.bz2;name=kernel \
9 http://rtp-net.org/ipaq/patches/2.6.14-3/v2.6.14-gitcurrent.patch;name=patch1 \
10 http://rtp-net.org/ipaq/patches/2.6.14-3/full.patch;name=patch2 \
11 file://defconfig"
13 S = "${WORKDIR}/linux-2.6.14"
15 inherit kernel
17 do_configure() {
18 install -m 0644 ${WORKDIR}/defconfig ${S}/.config
19 yes '' | oe_runmake oldconfig
22 SRC_URI[kernel.md5sum] = "66d02cbd723876c6d69846a067875a22"
23 SRC_URI[kernel.sha256sum] = "cc56285834bed461fd405c00a34d3c3095673333b94621580eeeb0c65237af15"
24 SRC_URI[patch1.md5sum] = "e0b42e51630e9cd7e3b0adf1be42f4a1"
25 SRC_URI[patch1.sha256sum] = "0c625e90d13f91269d3a02ebdfba97226651a849ad8d69a0734bb5df7964c571"
26 SRC_URI[patch2.md5sum] = "d7ec27a9b44eed194426038640af5460"
27 SRC_URI[patch2.sha256sum] = "70e8e8230390fb355d62270764f18f6b553bcb9383ddabfbed4a1238b0e79b80"