ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / linux / linux-colinux_2.6.10.bb
blobd86f3e2d7f8c8efc07953e9c2a2cba1d24ee5b99
1 SECTION = "kernel"
2 DESCRIPTION = "User Mode Linux Kernel"
3 LICENSE = "GPLv2"
4 COLV = "0.6.2"
6 COMPATIBLE_MACHINE = "colinux"
8 #http://internap.dl.sourceforge.net/sourceforge/colinux/coLinux-${COLV}.tar.gz
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
10 file://colinux-${COLV}.patch \
11 file://defconfig"
13 S = "${WORKDIR}/linux-${PV}"
15 inherit kernel
17 COMPATIBLE_HOST = "i.86.*-linux"
18 KERNEL_IMAGETYPE = "vmlinux"
19 KERNEL_OUTPUT = "./${KERNEL_IMAGETYPE}"
21 do_configure() {
22 echo '-co-${COLV}' > localversion-cooperative
23 install -m 0644 ${WORKDIR}/defconfig .config
24 kernel_do_configure
27 SRC_URI[kernel.md5sum] = "cffcd2919d9c8ef793ce1ac07a440eda"
28 SRC_URI[kernel.sha256sum] = "21646736755faee214f489b7388e6c47f5bcf6c2df64298ed2597104fabb8f0e"