1 DESCRIPTION
= "Libraries and applications to facilitate working with GPS data for research and high accuracy uses."
2 HOMEPAGE
= "http://www.gpstk.org/"
8 SRC_URI
= "${SOURCEFORGE_MIRROR}/gpstk/gpstk-${PV}-src.tar.gz \
9 file://configure.patch"
11 inherit autotools lib_package
13 EXTRA_OECONF
= "--enable-shared"
15 # This is a handcrafted do_install because 'make install' isn't working.
16 # This should install the same files as my native
(x86
) jam based build
, but doesn't since the Makefiles
17 # aren't up
to date
(e.g. bc2sp3 is missing
).
21 install
-d $
{D
}$
{bindir
}
22 install
-d $
{D
}$
{libdir
}
23 install
-d $
{D
}$
{includedir
}/
25 for i in bc2sp3 calgps DDBase ddmerge DiscFix EditRinex ephdiff example1 example2 example3 example4 example5 \
26 fic2rin ficacheck ficafic ficcheck ficdiff ficfica findMoreThan12 IonoBias mergeFIC mergeRinMet \
27 mergeRinNav mergeRinObs mergeSRI mkord mpsolve navdmp NavMerge novaRinex ordClock ordEdit ordGen \
28 ordLinEs ordPlot ordStats poscvt posInterp PRSolve ResCor resplot reszilla RinexDump rinexpvt \
29 rinexthin RinSum rmwcheck rmwdiff rnwcheck rnwdiff rowcheck rowdiff rstats rtAshtech sp3version \
30 TECMaps timeconvert tnl tsrif tsrifsu tsriftu vecsol wheresat
31 do install
-m
755 `find .
-name $i` $
{D
}$
{bindir
}/ ||
true
33 cp
-pPr src
/.libs
/libgps
* $
{D
}$
{libdir
}/
35 for i in AlmanacStore.hpp AlmOrbit.hpp ANSITime.hpp Bancroft.hpp BasicFramework.hpp BCEphemerisStore.hpp \
36 BinexData.hpp BinexFilterOperators.hpp BinexStream.hpp BinUtils.hpp BivarStats.hpp CheckPRData.hpp \
37 CivilTime.hpp ClockModel.hpp CodeBuffer.hpp CommandOption.hpp CommandOptionParser.hpp \
38 CommandOptionWithCommonTimeArg.hpp CommandOptionWithPositionArg.hpp CommandOptionWithTimeArg.hpp \
39 CommonTime.hpp convhelp.hpp DayTime.hpp DOP.hpp ECEF.hpp EngAlmanac.hpp EngEphemeris.hpp EngNav.hpp \
40 EphemerisRange.hpp EphemerisStore.hpp EpochClockModel.hpp Exception.hpp Expression.hpp ExtractC1.hpp \
41 ExtractCombinationData.hpp ExtractD1.hpp ExtractD2.hpp ExtractData.hpp ExtractL1.hpp ExtractL2.hpp \
42 ExtractLC.hpp ExtractP1.hpp ExtractP2.hpp ExtractPC.hpp FFBinaryStream.hpp FFData.hpp FFStreamError.hpp \
43 FFStream.hpp FFTextStream.hpp FICAStream.hpp FICBase.hpp FICData109.hpp FICData162.hpp FICData62.hpp \
44 FICData9.hpp FICData.hpp FICFilterOperators.hpp FICHeader.hpp FICStreamBase.hpp FICStream.hpp \
45 FileFilterFrame.hpp FileFilterFrameWithHeader.hpp FileFilter.hpp FileHunter.hpp FileSpec.hpp \
46 FileStore.hpp FileUtils.hpp GenXSequence.hpp Geodetic.hpp GeoidModel.hpp geometry.hpp getopt.h \
47 gps_constants.hpp GPSEpochWeekSecond.hpp GPSGeoid.hpp gpstkplatform.h GPSWeekSecond.hpp GPSWeekZcount.hpp \
48 GPSZcount29.hpp GPSZcount32.hpp GPSZcount.hpp icd_200_constants.hpp IonoModel.hpp IonoModelStore.hpp \
49 JulianDate.hpp LinearClockModel.hpp LoopedFramework.hpp MathBase.hpp MatrixBase.hpp \
50 MatrixBaseOperators.hpp MatrixFunctors.hpp Matrix.hpp MatrixImplementation.hpp MatrixOperators.hpp \
51 mergePCodeWords.h MiscMath.hpp MJD.hpp ModeledPR.hpp ModeledPseudorangeBase.hpp ModeledReferencePR.hpp \
52 MOPSWeight.hpp MSCData.hpp MSCStream.hpp ObsClockModel.hpp ObsEpochMap.hpp ObsID.hpp ObsRngDev.hpp \
53 ORDEpoch.hpp PCodeConst.hpp PolyFit.hpp Position.hpp PRSolution.hpp RACRotation.hpp \
54 RinexEphemerisStore.hpp RinexMetBase.hpp RinexMetData.hpp RinexMetFilterOperators.hpp \
55 RinexMetHeader.hpp RinexMetStream.hpp RinexNavBase.hpp RinexNavData.hpp RinexNavFilterOperators.hpp \
56 RinexNavHeader.hpp RinexNavStream.hpp RinexObsBase.hpp RinexObsData.hpp RinexObsFilterOperators.hpp \
57 RinexObsHeader.hpp RinexObsID.hpp RinexObsStream.hpp RinexSatID.hpp RinexUtilities.hpp RTFileFrame.hpp \
58 RungeKutta4.hpp SatID.hpp SimpleIURAWeight.hpp SMODFData.hpp SMODFStream.hpp SolverBase.hpp SolverLMS.hpp \
59 SolverWMS.hpp SP3Base.hpp SP3Data.hpp SP3EphemerisStore.hpp SP3Header.hpp SP3SatID.hpp SP3Stream.hpp \
60 Stats.hpp stl_helpers.hpp StringUtils.hpp SVExclusionList.hpp SVPCodeGen.hpp SystemTime.hpp \
61 TabularEphemerisStore.hpp TimeConstants.hpp TimeConverters.hpp TimeString.hpp TimeTag.hpp Triple.hpp \
62 TropModel.hpp UnixTime.hpp ValidType.hpp VectorBase.hpp VectorBaseOperators.hpp \
63 Vector.hpp VectorOperators.hpp WeightBase.hpp WGS84Geoid.hpp WxObsMap.hpp X1Sequence.hpp \
64 X2Sequence.hpp Xvt.hpp YDSTime.hpp
65 do install
-m
644 `find .
-name $i` $
{D
}$
{includedir
}/ ||
true
69 SRC_URI
[md5sum
] = "541ec5a5b86cf9e56f0b23cf6c80dd6e"
70 SRC_URI
[sha256sum
] = "c1378384b1737b2fa330f8d63d7777db311c976bb20e0c0e0fcd5dac0e78672a"