ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / cumulus / cumulus_1.2.1.bb
blobe636a7ff6b69f9094562110fa017cb2ec7d7eb55
1 DESCRIPTION = "A flightcomputer application for Qt/E based Palmtop Environments"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 APPTYPE = "binary"
6 APPNAME = "cumulus"
7 APPDESKTOP = "${S}"
8 PR = "r1"
10 SRC_URI = "http://www.kflog.org/fileadmin/user_upload/cumulus_downloads/${PV}/cumulus-${PV}.src.tar.bz2 \
11 file://open_max.patch"
12 S = "${WORKDIR}/cumulus_${PV}/cumulus"
14 inherit opie
16 export OE_QMAKE_LINK="${CXX}"
17 EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=-I."
20 # nasty hack since cumulus doesn't obey the qmake standard which requires just one .pro file per directory
22 do_compile() {
23 echo "#define SHARP_PDA_WARNSOUND 4" >sharp_char.h
24 qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} cumulus.pro
25 oe_runmake
26 qmake -makefile -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} gpsClient.pro
27 oe_runmake
30 do_install() {
31 install -d ${D}${palmtopdir}/pics/mapicons \
32 ${D}${palmtopdir}/pics/mapicons/small \
33 ${D}${palmtopdir}/pics/mapicons/windarrows \
34 ${D}${palmtopdir}/bin
35 install -m 0644 ../cumulus.png ${D}${palmtopdir}/pics/cumulus.png
36 install -m 0644 map-icons/*.png ${D}${palmtopdir}/pics/mapicons
37 install -m 0644 map-icons/*.xpm ${D}${palmtopdir}/pics/mapicons
38 install -m 0644 map-icons/small/*.png ${D}${palmtopdir}/pics/mapicons/small
39 install -m 0644 map-icons/small/*.xpm ${D}${palmtopdir}/pics/mapicons/small
40 install -m 0644 map-icons/windarrows/*.png ${D}${palmtopdir}/pics/mapicons/windarrows
42 install -m 0755 gpsClient ${D}${palmtopdir}/bin/
45 SRC_URI[md5sum] = "a13e49376594c51fbfa74067f8d14d45"
46 SRC_URI[sha256sum] = "e3ed263ee98971674f3f3cf55e42b7f2e79755b0f931f8a105676108185e8010"