ti-ocf-crypto-module: add crypto module for hw accel
[openembedded.git] / recipes / ctrlproxy / ctrlproxy_2.6.2.bb
blob11909aa15e4727d6ca7b192cee7d268bc41273d9
1 DESCRIPTION = "ctrlproxy is an IRC server with multiserver support."
2 SECTION = "console/network"
3 PRIORITY = "optional"
4 DEPENDS = "glib-2.0 libxml2 popt libpcre openssl"
5 PR = "r1"
6 LICENSE = "GPL"
8 SRC_URI = "http://sources.nslu2-linux.org/sources/ctrlproxy-2.6.2.tar.gz"
9 S = "${WORKDIR}/ctrlproxy-2.6.2/"
11 inherit autotools
12 # update-rc.d
14 #INITSCRIPT_NAME = "ctrlproxy"
15 #INITSCRIPT_PARAMS = "defaults 84"
16 # CONFFILES_${PN} = "${sysconfdir}/foo.conf"
18 # To fix this error in autotools_do_configure (which arises after a
19 # change to pkg-config pkg.m4):
20 #configure:314: error: possibly undefined macro: PKG_LIBS
21 do_configure() {
22 oe_runconf
25 CFLAGS += "-L${STAGING_LIBDIR}"
27 #do_install() {
28 # autotools_do_install
29 # install -d ${D}${sysconfdir}
30 # install -d ${D}${sysconfdir}/init.d
31 # install -m 0644 ${S}contrib/foo.conf ${D}${sysconfdir}
32 # install -m 0755 ${WORKDIR}/foo.init ${D}${sysconfdir}/init.d/foo
36 SRC_URI[md5sum] = "37570a7f018f41d701cd29cd95b45241"
37 SRC_URI[sha256sum] = "c8c42cc08b9b462f9c497441dacde1eac71fd717195ddfbeac68141bd0ad95a8"