libomxil: update to 0.9.2.1
[openembedded.git] / recipes / python / python-lxml_2.2.6.bb
blob93280f1fb46caa84b9d11d6200750df5bcec3bfb
1 DESCRIPTION = "Powerful and Pythonic XML processing library combining \
2 libxml2/libxslt with the ElementTree API."
3 HOMEPAGE = "http://codespeak.net/lxml"
4 LICENSE = "BSD"
5 SRCNAME = "lxml"
6 PR = "r0"
7 DEPENDS = "libxml2 libxslt"
8 RDEPENDS_${PN} += "libxml2 libxslt python-compression"
10 SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=lxml"
11 SRC_URI[lxml.md5sum] = "b1f700fb22d7ee9b977ee3eceb65b20c"
12 SRC_URI[lxml.sha256sum] = "7fd36e4a56360cd5d7319e357b04a90e2c6b836ea220c88f9451c300ae33cc5e"
14 S = "${WORKDIR}/${SRCNAME}-${PV}"
16 inherit setuptools
18 DISTUTILS_BUILD_ARGS += " \
19 --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
20 --with-xml2-config='${STAGING_BINDIR_NATIVE}/xml2-config' \
23 DISTUTILS_INSTALL_ARGS += " \
24 --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
25 --with-xml2-config='${STAGING_BINDIR_NATIVE}/xml2-config' \